So I messed up my phone.

Paul627g

AC Moderator All-Star
Moderator
Nov 25, 2010
15,963
2,752
0
Visit site
Hmmm .. I'm confused as to why its not erasing the old ROM as you claim...

Odin is intended to literally overwrite & wipe the device's system partition, etc where all the actual OS is contained.

Then my instructions to manually flash and your screen shots verify it did in fact write the stock v2.3.4 Gingerbread images to your device...

Thinking.. o_0
 

hlxanthus

Well-known member
May 22, 2011
1,790
411
0
Visit site
Have you removed all other files from Odin? If you just added the new stuff it could be trying to flash it all and could cause the problems you are having. (Never used odin but I think this is how it works). I would try unistalling everything, reinstalling it and try again.

Sent from my Nexus S 4G using Tapatalk 2
 

Paul627g

AC Moderator All-Star
Moderator
Nov 25, 2010
15,963
2,752
0
Visit site
Have you removed all other files from Odin? If you just added the new stuff it could be trying to flash it all and could cause the problems you are having. (Never used odin but I think this is how it works). I would try unistalling everything, reinstalling it and try again.

Sent from my Nexus S 4G using Tapatalk 2
Odin is pretty straight forward. You have normally 2 or 3 files.

1. Is the modem/radio
2. Another is called the ".pit" file which handles the partition sizes of the device (this isn't always used.. Depends on the setup of the package your flashing)
3. Third is the rest of the package in one, system/kernel/bootloader/boot/recovery,etc..

Really you don't want to mess with any of these files, you take them as they are and use them. Altering or changing something is a good way to brick your device.
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
To be honest unless u get a tech geek who does the same as you have done (unlock n root), sprint may not even touch the phone. A thought I had is u know how to use Odin, couldn't u load another time in the same method (leaked 4.0.4 I.C.S. from Sprint) or any other rom. It sucks that it's been so complicated for you. If u could in lock ur phone n install the files on ur USB memory of the phone it may force the phone to default. Have you tried rom manager to delete the troublesome rom?


Well the only way to get it to start now is if I use Odin to install the 4.0.4. It will not start a fresh 4.0.4 but rather the old tore up ROM. The weird thing is that it starts that rom but the phone itself is not Rooted anymore. Superuser is not installed (even though I know the superuser zip is in the USB Storage) and whenever I try to start any of the old apps I used to have NONE run. Even though all the icons are on my home screen and other screens and what not.

And you are right about ROM Manager, I think the backups I made there are what are causing the problem. What I am going to do or have my friend do (since I dont know how to root the phone from Windows or MAC or what executable commands to run and whatnot) is RE ROOT my phone and hope ROM Manager or Titanium Backup and delete stuff from there since I feel a backup is causing this problem. The thing is now that I remember I remember I deleted all the ROM Backups on ROM Manager and I checked on the storage and they were all still there under back up folders and each backup took up like 1GB of space.

The funny thing throughout this whole process is that I have like 4 GB of free storage on the USB Storage and I have added, deleted, wiped, erased, alll kinda stuff and huge sized files, and the storage is still EXAAACTLY the same as it has been since before all this started haha :(
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
Hmmm .. I'm confused as to why its not erasing the old ROM as you claim...

Odin is intended to literally overwrite & wipe the device's system partition, etc where all the actual OS is contained.

Then my instructions to manually flash and your screen shots verify it did in fact write the stock v2.3.4 Gingerbread images to your device...

Thinking.. o_0

Yeah man its pretty crazy.

I attached pictures to try and take you through my journey!! Haha :(
First pic is The Google screen after I followed your directions to do GB stock.

2nd pic, interesting because it went from the Yellow Android guy sweeping in bootload mode (i attached a pic earlier) to this different Bootload Screen...almost like its the GB bootload screen no?

3rd pic, So since it froze I installed 4.0.4 with Odin again.

So the phone started and the ICS boot animation came up and it took a while to start I was hoping it was wiping this time and going to start fresh or something but no...it started and it looked like this (4th pic) which is what my phone looked like exactly before this mess started. If I remember correctly its how it looked when I made one of my last backups on ROM manager.

So like android tooley suggested I just tried to get into ROM Manager and surprisingly it actually started I was like WTF! Haha. And I went into the backups section and there were 3 ROM Backups. I tried to install one just for the hell of it since I tried anything anyway and and it rebooted and the following screen came up (5th pic) ...its like an Android guy open with like a Red Yield thing... I just restarted the phone and am back on it now. I tried to start ROM Manager again to do stuff from it but it just says unfortunately ROM Manager has closed like it does with 99% of anything else i try to start. But I think if I start it right after the phone starts it will start for some reason.

I just went into the USB Storage with Astro File Manager and every single file that has been there from the beggining is still there including the Folder "clockwork mod" that has the backups that I think is causing the problems. I still have the same 4Gb of space


The last pic is a picture of the phone info I dont know if that helps and the phone options when ima shut it down still have reboot and other options I know are not from the stock ics. Aside from that like I have said before every other screen including the home screen one have all the same app icons that i had before, games, etc ...except hitting on any of them just says "unfortunately ___ has stopped"

So again, the phone starts with the tore up ROM. I should be able to do something with it starting but what hmmmmm
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
Have you removed all other files from Odin? If you just added the new stuff it could be trying to flash it all and could cause the problems you are having. (Never used odin but I think this is how it works). I would try unistalling everything, reinstalling it and try again.

Sent from my Nexus S 4G using Tapatalk 2

What do you mean removed all files from ODIN? I run the program 1.85 from their site I downloaded, and I follow the method on here to install the 4.0.4 leak. I dont really do anything else. hmmm i dont know what you mean by uninstalling everything.. you mean unzipping the odin program from the .zip somewhere else? to another directory or something?
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
Odin is pretty straight forward. You have normally 2 or 3 files.

1. Is the modem/radio
2. Another is called the ".pit" file which handles the partition sizes of the device (this isn't always used.. Depends on the setup of the package your flashing)
3. Third is the rest of the package in one, system/kernel/bootloader/boot/recovery,etc..

Really you don't want to mess with any of these files, you take them as they are and use them. Altering or changing something is a good way to brick your device.

Hmmmm could this .pit file aide whatsoever? Maybe somehow reformat the damn partition or something so the storage gets wiped or something?

On Odin i even checked Re Partition and all kinda other things to try and force it to wipe the storage or something but with these things checked The Process would not go through and it wouldnt start
 

TOOLEY

Well-known member
Apr 4, 2012
117
7
0
Visit site
Trying Googling one click nexus s 4g you may be able to download it before I can upload it. The file u want is one click nexus s 4g 51 MB, gives u option to unlock also if needed. I'll try to upload my copy tonight.
 
Last edited:

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
Trying Googling one click nexus s 4g you may be able to download it before I can upload it. The file u want is one click nexus s 4g 51 MB, gives u option to unlock also if needed. I'll try to upload my copy tonight.

Doesnt this one click Nexus S 4G thing do (automatically) what I did manually that Paul627G said to do the command prompt stuff?
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
Trying Googling one click nexus s 4g you may be able to download it before I can upload it. The file u want is one click nexus s 4g 51 MB, gives u option to unlock also if needed. I'll try to upload my copy tonight.

The only one clicks I have are like 100MB

and I have a one click nexus s 4g but its like 10 MB and I think its to root....
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
I found one but it is the one I already have. The one where you click the run .bat file and it does it by itself all you have to do is press Y. But remember I cant get my phone into debugging mode. Whatever I do it has to be from the Bootload screen or the fast boot screen it seems I have been the closest to fixing it when doing something from either of these two places
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
Wow this is interesting stuff...using the same method Paul gave me earlier with the command prompt on the FastBoot screen I was able to install ClockWorkMod Recovery hmmm......

now I have ClockWorkMod recovery and the messed up ROM but baby steps!!!O:)

I see a mounts and storage option on this Recovery hmm... I wonder what I can do with that...

Wow...with this Clockwork Mod Recovery thing I can Mount my USB Storage from the Recovery to my PC....

Since I was able to install clockwork mod and I can navigate files on the storage now I tried to install ROMS on there just for the hell of it to see if something different starts and No. I installed some APEX Rom and the same ole tore up rom started
 
Last edited:

TOOLEY

Well-known member
Apr 4, 2012
117
7
0
Visit site
http://db.tt/MKsOOqzG one click nexus s 4G zip to folder. Select run n follow prompts to obtained root n/or unlock. Easy to root then perhaps u can access ur rooted apparently (rom manager). Just a thought. Shouldn't delete anything just add root.
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
http://db.tt/MKsOOqzG one click nexus s 4G zip to folder. Select run n follow prompts to obtained root n/or unlock. Easy to root then perhaps u can access ur rooted apparently (rom manager). Just a thought. Shouldn't delete anything just add root.

Its interesting man I installed ClockWorkMod and I am just messing with all kinda options haha and I hit something that said "Fix Permissions" and Now I restarted the phone (even though it is still on that tore up rom) USB Debugging is working Hmm...
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
http://db.tt/MKsOOqzG one click nexus s 4G zip to folder. Select run n follow prompts to obtained root n/or unlock. Easy to root then perhaps u can access ur rooted apparently (rom manager). Just a thought. Shouldn't delete anything just add root.

The Good news is I followed your guide and at first there was an error that said (this device is already unlocked) but I proceeded to the next step. I followed all the steps, but when I got to the final step that said "Scroll down and find root.zip" and install there was no file called root.zip. :( ...but I mean...

I think that "fixed permissions" thing fixed some things. Even though I keep starting on the messed up ROM I can now run some apps it seems without the error message. I just ran the messages Window succesfully and also The Phone app.

I also ran Wi Fi Tether just to see if it ran (and even though my phone is not activated) and it said "Wifi Tether has been granted SuperUser Permissions"

So I think I am rooted now..or atleast the root is fixed or something.

So Update: I still cant write or delete anything on the USB Storage, but it seems I can probably activate my phone and use it. USB Debugging works, I have ClockWord Mod now...and it seems to be rooted (again)

The Problem would be Imagine trying to activate this thing with a Sprint rep being that I have something that is not the Stock ROM.

Ideally, ima still try to find a way to restore this thing to factory GB or ICS either or. So I am going to keep trying. and just leave it on now with this tore up ROM being that it seems to be running a little better.

Hmmmm...... I am trying to think what should be my next step ...

I wonder if I should try something from this thread like the One Click Return to Stock
but maybe do something things from ClockWork Mod before or something
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
So I went to Settings then "Erase USB Storage" "Return phone to factory settings"

and it rebooted

and now there is a White Triangle with an orange Exclamation Point inside with a little green adroid guy below it....

interesting.

I did a battery pull, restarted the phone and it is restarting and bam it starts once again on the backed up state it keeps starting (the picture with my home screen on it)

I keep installing different ROMS from the sd card or backups, and no matter which I install they all start the same ole rom (the picture with my home screen on it)
 

BenjaSands

Well-known member
Feb 24, 2011
299
3
0
Visit site
http://db.tt/MKsOOqzG one click nexus s 4G zip to folder. Select run n follow prompts to obtained root n/or unlock. Easy to root then perhaps u can access ur rooted apparently (rom manager). Just a thought. Shouldn't delete anything just add root.

Oh so I was able to access ROM Manager and I deleted the 3 backups there. One by one. And I restarted the phone into recovery and went to "Restore" and all 3 backups are still there....


It seems the reason nothing is getting done is because something is keeping everything from accessing the USB Storage. I just deleted the clockworkmod folder and Titanium Backup folder from the storage to see if I could and it deleted. Mounted again, and they were there agaiN!! THat **** is so frustrating
 
Last edited:

Members online

Forum statistics

Threads
944,554
Messages
6,923,356
Members
3,159,621
Latest member
wadeharper