Software updated to LS670ZVC: Now I can't connect to wi-fi N router with hidden SSID

TigerDave99

Well-known member
Jan 18, 2011
78
1
0
Visit site
I just read:

http://forum.androidcentral.com/lg-optimus-s/59769-just-got-update-sprint-wifi-no-longer-works.html

but my problem differs. Ever since the LS670ZVC software update last week, I can no longer connect to my TrendNet TEW-633GR EWC Wireless N router with either of my Optimus S phones. My SSID is set to "invisible" on my router. It used to work, but now the phones only see the router when the SSID is visible. The moment I hide it, the phones report that the SSID is "Not in range".

I am using "WPA/WPA2 PSK" security on my router, but I don't really think it matters.

Anyone else having probs connecting to wireless routers with hidden SSID's after performing the LS670ZVC software update?
 

sfhub

Well-known member
Jan 15, 2011
2,384
741
0
Visit site
Have a 802.11g network with SSID set to not broadcast. Optimus S with VC is able to connect and use the network. WPA2 PSK.
 

TigerDave99

Well-known member
Jan 18, 2011
78
1
0
Visit site
Hmmm, this is all very bizarre. I've already rebooted both phones and my router. No luck. Will keep troubleshooting and post any results here.

Still open for suggestions or want to hear from anyone else with this issue.
 

sfhub

Well-known member
Jan 15, 2011
2,384
741
0
Visit site
It's possible there is some interaction problem between some models of chipsets.

I've been testing the WiFi hotspot feature on the Optimus S. With two Intel WiFi cards (2200BG and 5100AGN) I get perfect connections. With a Dell 1390 (broadcom-based) WiFi card, I get 10-20% packet loss which makes the connection dog slow.

Over the years, I've seen in release notes of various WiFi card drivers fixes for SSIDs not set to broadcast and compatibility between different manufacturers.

Not saying your problem is definitely a problem like this, but something you could investigate. Try/borrow a router with a different chipset and see if that makes a difference. Alternatively you could revert your Optimus to V9 and test that version again. I think testing a different router would be less effort, but I have lots of those things lying around.

BTW I don't think the Optimus S supports 802.11n. I've only seen it show up as an 802.11b/g device so it is probably connecting to your router in 802.11g mode.
 

TigerDave99

Well-known member
Jan 18, 2011
78
1
0
Visit site
Yeah, I'm familiar with those wireless NICs found in various Dell laptops. Some are great and others are terrible. Unfortunately, I don't have a spare router to test with at this time.

You are correct, the Optiums S does not support Wireless-N. It is connecting to my router in wireless-G mode.

Thing is, this was working fine until the recent software update. For now, I have my SSID set to "visible" (broadcasting) until I can fix the issue.
 

chardog

Well-known member
Dec 3, 2010
47
5
0
Visit site
try a reboot, and make it visible permanantly. WPA2 is impossible to crack isnt it? I set up my system to have a nice long pass phrase, with caps, numbers, and characters. Brute force sure as hell not going to happen.
 

TigerDave99

Well-known member
Jan 18, 2011
78
1
0
Visit site
Change to channel 1,6, or 11. Set channel width to auto or 20mhz. Then test

No luck. Didn't matter which channel I tried or whether I selected "20MHz" versus "Auto 20/40MHz", nothing worked when I set the router to have an invisible SSID. I tried all possible combinations, still no go. And there hasn't been a firmware update for my router since July 2009. Probably won't ever be one either because routers are like seasons -- they are phased out within months.

try a reboot, and make it visible permanantly. WPA2 is impossible to crack isnt it? I set up my system to have a nice long pass phrase, with caps, numbers, and characters. Brute force sure as hell not going to happen.

I already rebooted my router and phone multiple times. Still no dice. Yes, WPA2 is virtually impossible to crack. I do prefer having the SSID hidden for that extra layer of protection from snooping noobs (somewhat important to me), but I'll live if it is displayed -- if that's what it takes for the Optimus S to work with my local wi-fi (very important to me). That said, I am using a rather long passphrase, so I think I'm good. It's just strange that it used to work fine prior to the latest update!

WPA2 has nothing to do with seeing an AP that is configured to not broadcast SSID.

Yup. Exactly.
 

sfhub

Well-known member
Jan 15, 2011
2,384
741
0
Visit site
You can try reverting to V9 just to confirm VC caused the problem. Perhaps it'll then get fixed sometime in the future.
 

dvdxyz

New member
Feb 18, 2011
1
0
0
Visit site
Optimus requires Wifi to Broadcast ssid

Picked up the LG Optimus V yesterday and tried connecting to my home wifi network. For initial setup, reconfigured my home wifi network to broadcast SSID. (Usually I keep SSID broadcast turned off.) Optimus connected wiithout issues. I then reconfigured my wifi router to stop broadcasting SSID and the Optimus immediately ended the wifi communication. Message on the phone shows network is 'not in range'.

I have dozens of devices connected to this same wifi network including several Android devices (Droid, Nexus One, Nexus S) but the LG Optimus is the only device I have ever come across that requires broadcast SSID to connect. To verify, I went to the T-Mobile store today and picked up an LG Optimus T. Brought home, turned on broadcast, connected successfully, turned off broadcast --- Same problem. I can only think this is a bug and it seems to plague the entire LG Optimus product set.
 

sfhub

Well-known member
Jan 15, 2011
2,384
741
0
Visit site
Well according to OP, it didn't happen in the previous Sprint V9 release of the firmware and only started after the VC release. Also it doesn't happen for me with VC or V9, so it isn't universal.

It does look like a bug though.
 

trekkie1701c

Well-known member
Nov 29, 2010
273
34
0
Visit site
Works fine for me... but then again, signal strength on WiFi has been weird. Should always show that I have a high strength when I'm at my desk (as the wifi router is right on top of my tower so it's literally a foot or so away from the phone), but it will sometimes show a low signal from time to time on WiFi before going back up to full.

Noticed it after the VC update, but didn't really pay attention to it before that.