TWRP Flash issues: LGG5 H850

  • Thread starter Android Central Question
  • Start date
A

Android Central Question

So basically I've been using this guide: link, I flash twrp to the device(tried multiple twrp versions):

PS C:\adb> fastboot flash recovery twrp.img
target reported max download size of 536870912 bytes
sending 'recovery' (19744 KB)...
OKAY [ 0.590s]
writing 'recovery'...
OKAY [ 0.186s]
finished. total time: 0.777s

Which looks like it works, then I try and boot into the recovery and get this error:

PS C:\adb> fastboot boot twrp.img
downloading 'boot.img'...
OKAY [ 0.589s]
booting...
FAILED (remote: unknown command)
finished. total time: 0.609s

I have manually entered the recovery menu, but it just factory resets the device instead of booting into twrp (Pressed Y twice on the recovery menu).The device is unlocked, and using android 7.0.1

PS C:\adb> fastboot getvar unlocked
unlocked: yes
finished. total time: 0.007s

Any ideas?
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
That "tried multiple twrp versions" bothers me. Have you tried the latest version for the 850 from https://twrp.me/lg/lgg5h830.html (not for another G5)? If there were problems with it, we would have been hearing screams for a while. The current version should be twrp-3.2.2-0-h830.img dated June 30, 2018.

Have you read Team Win's writeup on it?

Oh, and that's not how you "boot into recovery".

fastboot flash recovery twrp.img
fastboot reboot

Then you should be in TWRP.