USB port issue

midmofan

Well-known member
Oct 22, 2010
265
33
0
Visit site
Is anyone having a problem with the USB/charging connection being very sensitive.? With mine even the slightest "forward" pressure can make it lose connection. So much so that the weight of the plug and cord itself is enough so that the phone won't charge if placed face down.
 

Mikey47

Well-known member
Jun 8, 2010
2,007
122
0
Visit site
Is anyone having a problem with the USB/charging connection being very sensitive.? With mine even the slightest "forward" pressure can make it lose connection. So much so that the weight of the plug and cord itself is enough so that the phone won't charge if placed face down.

I foresee a return in your near future...

:(
 

ImNoPrince

Well-known member
May 7, 2012
169
16
0
Visit site
My OG EVo had the same problem right before it broke completely off the board. I was on Vacay in Cali when it happened and had 6 batteries with me and 2External Chargers.

Would hate for it to happen with this one . Take it in and have them at least look at it might be just a bad solder .
 

devgrp

Well-known member
May 17, 2010
98
19
8
Visit site
This is a problem with the way htc makes the charge port. It sucks. My Evo 3D and my GF EVO had problems with the charge port. Now I have to be extra careful when I plug it in to charge
 

ImNoPrince

Well-known member
May 7, 2012
169
16
0
Visit site
This is another reason I had Docks at the House and in all my Cars with the Micro built in. I will be getting them slowly for this one as well. I just think it's a more stable way to charge
 

1stva

New member
May 27, 2012
2
0
0
Visit site
Yes, having exact same issue using two charger cords that work perfectly for my original 4g. Weight of the cord alone is enough to pull the plug out of contact and stop charging and there is no way you can use the phone while charging. I see this being a real deal breaker for me, I fear I may have to return the phone. Totally bummed.
 

1stva

New member
May 27, 2012
2
0
0
Visit site
Follow-up. Just for grins and giggles I plugged in the short USB cable that came with the phone, and guess what, no issues. I had even tried "crimping" the end of the cable that plugs into the phone to make it tighter, no luck. But the factory cable worked fine, even with some fairly aggressive wiggling. Too bad that cable is so short and I only have one of them.

If any one else is having a similar problem with the USB charging cable on the evo 4 LTE,
I would like to know if using the factory cable solves the problem.
 

Members online

Forum statistics

Threads
944,419
Messages
6,922,749
Members
3,159,548
Latest member
MansiDaware