V7 Zyro - Problems with App compatibility and rooting/flashing the device

RichieTrager1988

New member
Aug 2, 2018
1
0
0
Visit site
Hi,

I've got my hands on a cheap chinese phone from a brand called "V7". The model is "Zyro". Unfortunately, the phone didn't come to me with pre-installed Google Play store. Nor is it rooted or flashed with custom recovery like TWRP. I wanted to install some apps on it via transferring data from PC to the phone. I've sourced apps such as Youtube, Facebook, Messenger, Google Internet Services, Google Play Store etc. from a trusted website apkmirror. Unfortunately, most of the apps seem to cause errors while attempting to install. The errors state that the apps are not meant "for this device". I've tried versions designed for numerous architectures such as 32 and 64 bit, as well as arm64-V8a based CPUs. I can't understand why is this happening as majority of those apps state in the description that they are either universal or are expected to work since Android 4.2 Jelly Bean. I have problems installing GBoard (Google Keyboard) and Samsung Keyboard on the device as I'm stuck with some chinese virtual input called "Sogou". I've tried to flash the device with custom recovery but unfortunately didn't find a version of TWRP which would be compatible with my device. The same happened when I've tried to find any sort of custom rom or even official, android stock rom. I would like to ask you:

1. What are possible causes of such majority of apps being not compatible with this device despite the fact that it seems to be a generic android phone?
2. Why universal input apps such as Google's Gboard crash after a while or do not install at all?
3. How can I safely flash the device with a custom recovery?

Thanks in advance :-*

Eva
 

SpookDroid

Ambassador
Jul 14, 2011
19,320
584
113
Visit site
If the device doesn't have support for Google Play Services, any app from Google or that uses Google's services is probably going to fail even if you try to manually install them (and some even have protection so you can't just do that).

Problem is that Google is blocked in China, and since they can't bundle anything Google there, the device just uses the free portion of Android and doesn't conform to Google's standards to allow access to their Play Store (similar to how Amazon devices use a forked version of Android, but can't access the Play Store out of the box). There are ways to hack a device and make these services available, but that is beyond my expertise (pretty sure a Google Search might help).
 

Forum statistics

Threads
943,737
Messages
6,919,846
Members
3,159,199
Latest member
Hapily02