Verizon Motorola Droid Turbo Wireless Charging...I've been on 100% for 24hrs of use?

zagato27

Well-known member
Dec 3, 2010
81
0
0
Visit site
Got my Turbo last week and learning it. One of the features that I liked and wanted out of the box was wireless charging. Bought a CHOE Stadium Qi wireless charger from Amazon and it arrived yesterday. Put the Turbo on it and up popped a screen saying to center the target on the "bullseye" mark on the charger. Ok, no problem. Kind of thought I'd get a message saying wireless charging but no problem. Charged overnight and had 100% when I went off to work at 0600. Used the phone normally throughout the day making some calls and listening to an audio book. Well, I'm home now (1830) after 12 hours and the battery is still showing 100%. I wanted to get good battery life but I question this. BTW, I'm using a battery app GSAM and it too is saying 100%. Anyone have this happen? Kind of worried that the charger might have done something. I did power down the Turbo thinking it might refresh the battery display but it's still the same. So, do I have the first Turbo with an infinite battery? Ideas? Anybody?
 

elir41

Well-known member
Apr 25, 2010
68
3
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

I believe it's a bug the Turbo has with wireless charging. A few members from various forums reported the same thing.

Posted via the Android Central App
 

ven07

Q&A Team
Dec 10, 2014
11
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Wow!!! I want your phone!!! lol Did you try any other battery app? try a new one, soft reset the phone and check again
 

zagato27

Well-known member
Dec 3, 2010
81
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Both my GSAM battery indicator and the Motorola battery indicator show 100%. As to "soft" reset, I did turn the phone off and on but no change. Not sure another battery app will change but I might give it a whirl.
 

ven07

Q&A Team
Dec 10, 2014
11
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Both my GSAM battery indicator and the Motorola battery indicator show 100%. As to "soft" reset, I did turn the phone off and on but no change. Not sure another battery app will change but I might give it a whirl.

The extra battery app is simply a precaution lol.. That's what I would've done
 

doogald

Trusted Member
Jan 3, 2010
4,425
55
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

I believe it's a bug the Turbo has with wireless charging. A few members from various forums reported the same thing.

Posted via the Android Central App

+1. Read these threads:

http://forums.androidcentral.com/motorola-droid-turbo/470235-my-phone-went-28-dead.html
http://forums.androidcentral.com/motorola-droid-turbo/455116-droid-turbo-battery-life-27.html

Frankly, I'd stay away from Qi charging until there is a software update.
 

NoahForeman

Well-known member
Jul 8, 2014
140
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Try plugging in the turbo charger, booting to recovery, clearing cache, reboot. Leave it plugged in the while time. Usually fixes mine.

Posted via the Android Central App on my Droid Turbo.
 

Jay Evans

Well-known member
Apr 23, 2011
98
5
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Both my GSAM battery indicator and the Motorola battery indicator show 100%.

Had the same problem. Uninstalled GSAM, rebooted phone, charged overnight (wireless), rebooted again and haven't had a problem since.

Posted via the Android Central App
 

wolf_walker

Well-known member
Jan 29, 2013
168
0
16
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

had that happen too, I ended up clearing cache(which I've read since shouldn't have mattered), rebooting a couple times and charging till full wired and it got straight. Been using QI sense with no problems but I do believe there is a problem there. Had the same thing happen with my Nexus 7 one time, with a different QI charger.
 

Snareman

Well-known member
Nov 2, 2010
2,356
33
48
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

I had this happen as well. Lasted all day and a reboot didn't fix it. It eventually resolved itself that night.
 

swany1970

Well-known member
Apr 12, 2010
63
1
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

I've had this happen a couple of times. I did a soft reset and it was resolved. Press and hold the power button and volume down for about 5-10 seconds. Worked every time for me.
 

zagato27

Well-known member
Dec 3, 2010
81
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Well, I'm streaming a youtube movie and it's come down from 100% to about 86%. Least it's moving. I REALLY want to continue to use wireless charging. I'm hoping this is just a one time glitch.
 

bfranker

Well-known member
Apr 26, 2010
58
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

There is an issue with the hardware and/or software related to the battery with these Turbo phones. Mine was fairly consistent the first two weeks I had the phone and then the battery reporting went all haywire on me. I too had the issue where it stuck on 100% for hours and never went down. I ran the phone down, cleared cache, did a few things and it seemed like it was working properly for a couple days and now the last two days on the Qi charger for at least 9 hours it doesn't go above about 50%. Put it on the Turbo charger for about 5 hours earlier and it only went up a couple percent. I really hope this is a software issue and gets fixed with an update but just to let you know, there are many experiencing weird battery issues with this phone.
 

wolf_walker

Well-known member
Jan 29, 2013
168
0
16
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Speak of the devil... Put mine on the Qi pad at about 35% at 1am, woke up at 7am to a 60% battery at 121F...
Hour on the wired turbo charger and it's 100%/89F.

Wonder if trying to charge from a lowish % is too much for the Qi charger? It's one of the three coil deals, my Nexus 7 seems to do OK on it.
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
26
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Speak of the devil... Put mine on the Qi pad at about 35% at 1am, woke up at 7am to a 60% battery at 121F...
Hour on the wired turbo charger and it's 100%/89F.
The battery was still charging on the Qi charger (which usually runs around 600mA), so it and the Qi receiver were warm. An hour on the wired charger probably charged it before the hour was up, giving it a little time to cool down a bit (and the Qi receiver wasn't creating any heat).

The numbers look pretty normal.

Wonder if trying to charge from a lowish % is too much for the Qi charger? It's one of the three coil deals, my Nexus 7 seems to do OK on it.
Qi is Qi, one coil or 3, the electronics is the same. I've charged batteries (not mine - I don't abuse batteries) from 10% with Qi - the only problem is that, at 600mA, it takes a long time.

Of course, especially in a phone with a non-replaceable battery (not in the field, anyway), you should never let the battery get below 40%. Letting it drop down to low numbers regularly can catastrophically shorten the battery's life. Then, instead of popping in a new $15 battery, you pay a shop $150 to replace the internal one. (Drop the battery close to zero on every charge cycle and it won't last a year - and it's not usually covered by the warranty.)

As long as the charging current is higher than the discharge current (which is about 1mA total when the phone is off), the battery will charge - although it might take a few weeks to reach full charge. About the only way to charge a battery too slowly is to charge it at a lower rate than the combined self-discharge and the current being drawn from it - and even an old (like 15 years old) 100mA charger will give you more charge than that if the phone is turned off.
 

HappyFunBall24

Well-known member
Nov 29, 2014
209
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Of course, especially in a phone with a non-replaceable battery (not in the field, anyway), you should never let the battery get below 40%. Letting it drop down to low numbers regularly can catastrophically shorten the battery's life.

I've heard about not going below 20% but not 40%. Is this a hard and fast guideline? That is, I understand and agree with the concept behind it, but would there be a big difference between draining it to 20% as opposed to 40%?
 

wolf_walker

Well-known member
Jan 29, 2013
168
0
16
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Got me, I charge it every night on that pad and I don't think I've ever seen it that hot but if it's fully charged by morning
as it usually is, it may have cooled down by then.

GSAM battery history isn't showing the night before last for some reason, but looking at last night
it charged pretty smoothly from 35% at 1am, at 5am/60% it leveled off (still charging but barely) and the battery
temp dropped, then temp spiked at 7am. It did not charge linearly as I'd expect. Over that last
twenty minutes or so of (attempted) charging the battery temp went up 15 degrees.
Maybe something was using more power than Qi could supply.

Either way, if this does not become more consistent I'm going to quit using it.
Neat tech, little early maybe. I had the battery % get jacked up on my S4 once too from Qi.
 

doogald

Trusted Member
Jan 3, 2010
4,425
55
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Based on all of the people having problems with Qi on the turbo, I'd stop using it right now until there's an update from verizon that specifically states that it fixes problems with wireless charging.
 

zagato27

Well-known member
Dec 3, 2010
81
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

Well, I searched and indeed found other threads with the same problem that I had/have with the Turbo and Qi charging. It's a bit confusing. I wound up going on YouTube and streaming a movie. Bat % eventually came down and seemed to be acting normally. Drew it down to about 15% (oooops, did not read some of the responses regarding lo bat % and bat life...I won't let it go that low again) and then set it on the Choe charger. This morning it was 98%. During the day it was doing good. After about 10 hrs at work I was down around 70%. I'm going to charge it tonite on using Qi and see how it behaves. Hoping that the issue is resolved. Fingers crossed.
 

fonger13

Well-known member
Sep 23, 2013
129
0
0
Visit site
Re: Wireless Charging...I've been on 100% for 24hrs of use?

The 100% bug has hit me twice in the past month, I'm going to stop using Qi charging for a while to see if I can isolate the problem.
 

Forum statistics

Threads
943,017
Messages
6,916,900
Members
3,158,778
Latest member
dmitrbol