"Warning" Camera Failed

Sofastarch

New member
Sep 18, 2018
2
0
0
Visit site
Within a month or two of installing the Oreo 8.0 update on my S7 Edge, my camera is no longer working. First indication was when I had the camera open and multiple green lines were appearing in the screen like it was some sort of glitch-looking filter for a video. They disappeared shortly after and I just dismissed it as some kind of interference. Next, the camera would not open in snapchat, and when trying to load through the default camera app I would get "warning camera failed" which force closed the app. Verizon told me there was nothing they could do. I've checked for app updates, force stopped, cleared data.. the usual stuff. The strange thing is the camera will work in random occasions when I open snapchat- but then appear black again if I close the app and reopen so I'm not certain this is a hardware issue. I've read other instances of this issue and that reportedly it's not being considered a bug by Samsung because people have been able to resolve the issue with basic troubleshooting although I have not found any accounts of people definitively resolving it.

Any advice would be appreciated. Phone is almost two years old and has worked like new otherwise. Really don't want to shell out money for a new phone.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
91,547
6,129
113
Visit site
Within a month or two of installing the Oreo 8.0 update on my S7 Edge, my camera is no longer working. First indication was when I had the camera open and multiple green lines were appearing in the screen like it was some sort of glitch-looking filter for a video. They disappeared shortly after and I just dismissed it as some kind of interference. Next, the camera would not open in snapchat, and when trying to load through the default camera app I would get "warning camera failed" which force closed the app. Verizon told me there was nothing they could do. I've checked for app updates, force stopped, cleared data.. the usual stuff. The strange thing is the camera will work in random occasions when I open snapchat- but then appear black again if I close the app and reopen so I'm not certain this is a hardware issue. I've read other instances of this issue and that reportedly it's not being considered a bug by Samsung because people have been able to resolve the issue with basic troubleshooting although I have not found any accounts of people definitively resolving it.

Any advice would be appreciated. Phone is almost two years old and has worked like new otherwise. Really don't want to shell out money for a new phone.
Found your post by mistake , sorry no one helped you
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,563
4,700
113
Visit site
Too late to the party, but I would've suggested Safe Mode as an initial troubleshooting step.
 

Forum statistics

Threads
943,071
Messages
6,917,147
Members
3,158,809
Latest member
JaydenWhitfield