Watch 4 Classic Suddenly Not Sending Contact Names - But Sending Phone # In SMS

Kudzu Kid

New member
Nov 15, 2023
4
1
3
Visit site
Hi There,

A day or so ago, my Watch 4 Classic quit showing me the name of the sender when receiving a text message. Instead, I'll just see the phone # it came from and the text body itself. But on my phone, everything is correct (name, number, and text). It's highly possible I (or someone playing with my phone or watch - I have 3 VERY mischievous cats!! They love to sit on my nightstand or anywhere I set my watch and paw it, sit on it, throw it on floor, etc; etc.) managed to fat finger (fat paw) something. It's as if the phone isn't sending the name portion - or the phone isn't receiving it. But that doesn't make sense either - since it's getting everything else (the number, and the text itself). However, during an incoming PHONE call, I see full info (caller's name, phone #, and contact photo). I perused most settings I could think of but it's possible I'm just overlooking something.

Any & all hints & tips are appreciated!
 

SpookDroid

Ambassador
Jul 14, 2011
19,122
323
83
Visit site
On the watch, open the Settings and open the Security and Privacy section. There, scroll down to Permission Manager. Make sure that your messaging app has access to Contacts.
 
  • Like
Reactions: Kudzu Kid

SpookDroid

Ambassador
Jul 14, 2011
19,122
323
83
Visit site
It shouldn't have changed for Messages (it sometimes changes for apps you don't use in a while), but glad you got it sorted!
 

Kudzu Kid

New member
Nov 15, 2023
4
1
3
Visit site
Yeah - it remained intact for (incoming) calls, but had lost the contact (name) info and only displayed the incoming #. Thanks to you, I got it squared away.
=-=-=-=-=-=
Now, for my next trick, I've got to figure out why my Bose QC-35ii headphones keep losing connectivity to Google Assistant (on my phone). They maintain the Bluetooth pairing - as I can still play music, etc; but as soon as I power cycle/reset either one (which is inevitable over time) I have to UN-pair, RE-pair the headphones, walk through the Google Assistant set-up again, then I'm good to go - until the net reset, rinse repeat. But that discussion problem is probably beyond this forum/channel, though the phone is a Samsung S21+ 5G. I attribute this issue to a recent OS update (phone) but could be mistaken, but I've had to repeat this process over a half dozen times in the past month or two. It kind of sounds like a broken permissions issue or something to me. I can't blame the cats (or myself!) for this one. But I digress...

Thanks again for your help!

Cheers!
 

SpookDroid

Ambassador
Jul 14, 2011
19,122
323
83
Visit site
I would post this on a separate thread so it doesn't get lost in the shuffle, but first thing I'd try is deleting the connection to the headphones from your phone. Manually un-pair/delete the connection so that when you reboot you're asked to re-pair, and then go ahead and re-pair. Second, is there an app needed for the headphones perhaps? Do you happen to have any other headphones with the same model that may be interfering? What about pairing the headphones with another device, does the same thing happen, or is it just in your S21?
 
  • Like
Reactions: Kudzu Kid

Kudzu Kid

New member
Nov 15, 2023
4
1
3
Visit site
Hi SppokDroid,

Thanks for taking the time to respond. Yeah, I will post in a more appropriate forum soon. But, Yes, yesterday I discovered something weird. I could unpair the headphones & Google Assistant - and reinstall & re-pair and life is good... UNTIL I power cycle either the headphones and/or the phone. Once the pairing is 'interrupted' - it stays broken until I rinse/repeat (unpair, reinstall, etc.). This is a new problem and a capital PITA! I only have Google Assistant on my phone - and it always works (on the phone itself) - so I suspect it's some kind of Bose issue - but reportedly I'm using the latest update on it.

As you suggested, I'll move this to a more appropriate forum/channel. Not sure if there's one here - I will look around and see (I'm relatively new here).

Again, my thanks for your help and efforts here!
 

Trending Posts

Forum statistics

Threads
938,854
Messages
6,891,374
Members
3,156,418
Latest member
BootyBoater