what is up with battery % / calibration

sinfony78

Active member
Feb 1, 2011
35
0
0
Visit site
i've calibrated my battery several times, following the different methods in the XDA forums, and no matter which method i follow (drain, plug in till full, plug in power off, etc...) my battery perecentage isn't accurate...at times it will drop down 30% after a reboot

so what do i need to do, why is this not working?

if i pull out the battery and turn on, reboot with no charger, power off and on with charger plugged, or whatever random thing i decide to try next, my % will jump anywhere, from 8% to 40%

what is the deal here, why can't i get this thing to be accurate?
 

Paul627g

AC Moderator All-Star
Moderator
Nov 25, 2010
15,963
2,752
0
Visit site
I think this is still the same bug we've dealt with for some time. You can try "spare parts" from the market it will give you an accurate display of your battery information. It won't resolve the problem but a least you can what the true battery levels are.
 

sinfony78

Active member
Feb 1, 2011
35
0
0
Visit site
i'm at my wit's end here
friday i wiped everything, flashed the Syndicate ROM with battery at 100% and for 2 days had phone last over 20 hours...now i'm back to having the phone sit on standby draining up to 10% an hour with no usage

spare parts is giving me the same readings that quick battery and battery indicator give me, and since the flash, i've had a minimum number of applications installed...i'm not happy with this phone at all when i turn off data all day with quick settings and getting this kind of battery drain

this is the first time i've heard about a "bug"...i thought calibration would fix it
 

Paul627g

AC Moderator All-Star
Moderator
Nov 25, 2010
15,963
2,752
0
Visit site
i'm at my wit's end here
friday i wiped everything, flashed the Syndicate ROM with battery at 100% and for 2 days had phone last over 20 hours...now i'm back to having the phone sit on standby draining up to 10% an hour with no usage

spare parts is giving me the same readings that quick battery and battery indicator give me, and since the flash, i've had a minimum number of applications installed...i'm not happy with this phone at all when i turn off data all day with quick settings and getting this kind of battery drain

this is the first time i've heard about a "bug"...i thought calibration would fix it


Calibration does resolve it sometimes, but I have heard many people talk about rebooting and coming up with way off battery percentages on the reboot from what they shutdown at.. Example, shutdown with battery at 80% and it reboots a minute later and says 40%. Then out of nowhere it resets itself back to 80% or close.
 

Paul627g

AC Moderator All-Star
Moderator
Nov 25, 2010
15,963
2,752
0
Visit site
is there a possibility it's a bad battery?
Its possible, but if your phone is maintaining a reasonable charge for a good 6-8 hrs on average or more then I would think your battery is okay.. But I'm no battery expert.. LOL.
 

comets8518

Member
Jan 9, 2011
17
1
0
Visit site
perhaps its a way the software reads the voltage of the battery,...That is 4.2v = 100% full li-ion battery (most phones call anything close to 4.2v 100%)
3.7v = 50% etc etc..but all of these batteries have a discharge curve, which is actually dependent on how hard the battery is working (e.i. If its under heavy load/restarting the voltage may dip to 3.3, but once its not under load it will return to true voltage at 3.5 or 3.7 which would confuse the software.

I don't know if any of that is true with phones that may not be really putting the batteries under heavy load even at full discharge, but that is true of li-ion battery under heavy loads..in the multi amp ranges
 

garapueto

Well-known member
Feb 22, 2011
56
2
0
Visit site
I had this exact problem earlier today. I having trouble with my GPS so I rebooted and, once my phone came back up, the battery meter dropped to almost nothing. I run JuicePlotter (JuiceDefender widget) and it assured me I had several hours remaining. This turned out to be true as my phone lasted through more afternoon usage, several phone calls, and more usage.

I, too, would recommend some kinda of monitor to give you a more accurate estimate of life left.
 

persianpimp

Well-known member
Oct 25, 2010
75
2
0
Visit site
i'm at my wit's end here
friday i wiped everything, flashed the Syndicate ROM with battery at 100% and for 2 days had phone last over 20 hours...now i'm back to having the phone sit on standby draining up to 10% an hour with no usage

spare parts is giving me the same readings that quick battery and battery indicator give me, and since the flash, i've had a minimum number of applications installed...i'm not happy with this phone at all when i turn off data all day with quick settings and getting this kind of battery drain

this is the first time i've heard about a "bug"...i thought calibration would fix it

If you used to get battery up to 20 hours, then most likely your problem is Time Without signal (TWS). When you go to status, battery, see what it is killing ur battery.

There is a bug and my phone only last me 5 hours, it used to last me 2 days easy. Also make sure to turn off DRM and startup apps with the "Startup Editor" app. That app makes sure some apps dont open when you boot your phone, meaning there are no apps running that you don't use. Turn down brightness and haptic feedback.

I hate haptic feedback, it's like ur phone is a vibrator.. vibrates every second lol. Brightness... phone is bright even on low lol

Also, when you do the calibrating thing, you got to give it couple days i think. Because if you think about it, you have just wiped your battery stats. The reason i think you do everything before is to get to record the full life of the battery
 
Last edited:

persianpimp

Well-known member
Oct 25, 2010
75
2
0
Visit site
Also, if i was you, i would not run syndycate 1.02, there are so many problems with it. It has the potential to be one of the best roms, but it seems like it's not kept up. Mostly because i think Kroane is really busy and doesn't have time... but who knows
 

comets8518

Member
Jan 9, 2011
17
1
0
Visit site
perhaps its a way the software reads the voltage of the battery,...That is 4.2v = 100% full li-ion battery (most phones call anything close to 4.2v 100%)
3.7v = 50% etc etc..but all of these batteries have a discharge curve, which is actually dependent on how hard the battery is working (e.i. If its under heavy load/restarting the voltage may dip to 3.3, but once its not under load it will return to true voltage at 3.5 or 3.7 which would confuse the software.

I don't know if any of that is true with phones that may not be really putting the batteries under heavy load even at full discharge, but that is true of li-ion battery under heavy loads..in the multi amp ranges

I had the problem occur this weekend twice so I had a chance to look at it. My gps locked up..and restarted I went from 37% to 2%, and again it happend from 62% to 19% on restart.

The problem I believe is as stated, inaccurate reads. GPS status showed the exact same voltage of the battery pre/post restart, both times this happened.
The battery voltage is the true indicator of battery life.

As stated above with juice plotter (which I didnt use) my phone last a long time on 2% because it actuallly had more juice. I'm going to try juice plotter next time to see acurate data
 

jrz5024

Well-known member
Dec 12, 2010
244
27
0
Visit site
Also, if i was you, i would not run syndycate 1.02, there are so many problems with it. It has the potential to be one of the best roms, but it seems like it's not kept up. Mostly because i think Kroane is really busy and doesn't have time... but who knows

1.02 had problems at first, but they have all been long fixed, and what rom doesn't have bugs in the beginning? I'm still running 1.0.2 with zero bugs, problems or FCs whatsoever. And K0nane is supporting it actively, he released 1.1 days ago and 1.1.1 should be out anytime now...
 

Paul627g

AC Moderator All-Star
Moderator
Nov 25, 2010
15,963
2,752
0
Visit site
Syndicate 1.1.0 is has been out for about a week or so and is doing good. There are a few people still getting mixed battery life, but its limited. Not wide spread.
 

chris41g

Well-known member
Mar 25, 2011
75
63
0
Visit site
I use syndicate 1.1.0 with visionkernel and an app called green power, and I have heavy heavy usage, and its been pretty good as far as battery goes for me...
 

thebullfrog

Well-known member
Mar 9, 2011
202
13
0
Visit site
Well, I just ran into this myself. I was at 46%, rebooted and it came back on at 14%. Spare Parts reports the same thing. Something is definitely screwy, either with the ROM or a shared issue between Twilight and Vision (I assume OP is on the Twlight bundled with SRF).
 

Trending Posts

Forum statistics

Threads
941,583
Messages
6,909,508
Members
3,157,974
Latest member
aarone