Why are my gmail contacts not showing up?

Feb 19, 2016
14
0
0
Visit site
There are probably 30% of my Google Gmail contacts not showing up on my Samsung Galaxy S4. I have tried a Factory Default but still not working. I have the gmail app working plus added my google account to the email app. Both will not show the contacts.

Whenever I log into Gmail on my desktop, all contacts are there.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,484
4,619
113
Visit site
Go to Settings>Accounts-Google>[your account]. Is Contacts checked on? Also, open the Contacts app, tap Menu>Settings>Contacts to Display, and make sure it's set to All.
 
Feb 19, 2016
14
0
0
Visit site
Thanks. All settings are correct. After months of troubleshooting this, I finally took this into a Sprint store and took 2 hours for them to figure this out.
Had to export my contacts. Upload them to an iPhone 5. pass that to a Galaxy S5 then finally had that sync to my S4. Not sure what google is doing but there is definitely a bug going on.
 

anon(9444752)

Member
May 9, 2015
6
0
0
Visit site
Same problem here with my galaxy s4. I'm with verizon. 44/60 of my gmail contacts show in android. All 60 of them show in gmail when I log in at my computer. All android settings correct (google syncs on and working, contacts to display = "all contacts", etc). I wouldn't have noticed but today I received a text from a frequent contact and only the phone number showed up. Sometime in the middle of the night they disappeared. Any details on how to fix this? Should I try exporting and doing something similar as OP?
 

anon(9444752)

Member
May 9, 2015
6
0
0
Visit site
I found a workaround that restores the lost contacts. Login to gmail (on a computer) and edit contacts, then just make a small change to all your contacts. The easiest thing to do is add a "star". I just added a star to all my contacts, then removed the star. The 30% or so of missing contacts will then reappear in android. I have no idea why this happens in the first place, but at least I got my contacts back.
 

apexadam

New member
Apr 16, 2016
1
0
0
Visit site
Since January 2016 My Galaxy S4 fails to sync some contacts. There is no error. Google claims to Sync but contacts on my Google account suddenly disappear from my phone. The solutions in this thread suggested to edit the contact which worked on a few occasions but only temporarily and to edit 2800+ contacts is unreasonable. Am I alone in this? What are some solutions to this horror?
 

Richg12345

New member
Jul 12, 2016
1
0
0
Visit site
Merged contacts can also cause an issue with contacts not showing up. Tru entering the number in your phone and see what it shows up as. Separate contacts that may have merged during setup, or cause confusion because they are merged. (Several extensions in a large commercial operation for example )
 

Teboho Tebohoteboho

New member
May 27, 2017
1
0
0
Visit site
Go to:
Settings > Data usage > Android services > Restrict background data/services. (Make sure this is off).

Then:
Settings > Accounts > (choose account) > sync contacts. (Must be on).
Wait about two minutes and lemme know if you're good.

That's what worked for me.

✌amani!
 

Shen Long Lim

New member
Jan 23, 2018
1
0
0
Visit site
Same problem here with my galaxy s4. I'm with verizon. 44/60 of my gmail contacts show in android. All 60 of them show in gmail when I log in at my computer. All android settings correct (google syncs on and working, contacts to display = "all contacts", etc). I wouldn't have noticed but today I received a text from a frequent contact and only the phone number showed up. Sometime in the middle of the night they disappeared. Any details on how to fix this? Should I try exporting and doing something similar as OP?

For my case, I go to Google Contacts, found the disappeared contacts is stored under 'Other Contacts' group, I select those disappeared contacts, move it to My Contacts. My hp will sync the disappeared contacts. Hope it helps.
 

br13

New member
Mar 13, 2018
1
0
0
Visit site
Same problem with my S7, except worse. I found entries for many of the missing contacts by going through the contacts app, except it is worse. My daughter's name and picture are assigned to my husband's email address.

Verizon store manager spent 2 hours trying, but no help.
 

gepeng1983

New member
Apr 3, 2018
1
0
0
Visit site
Did you delete your Google plus profile? I did that and experienced a similar problem with my contacts in gmail app after a few hours. I tried all suggestions available on the internet but no fix. Today I tried a last resort - I created my Google plus profile again. Now all my contacts are back to gmail app.
 

waynezill@gmail.com

New member
Jan 10, 2018
3
0
0
Visit site
Go to:
Settings > Data usage > Android services > Restrict background data/services. (Make sure this is off).

Then:
Settings > Accounts > (choose account) > sync contacts. (Must be on).
Wait about two minutes and lemme know if you're good.

That's what worked for me.

✌amani!

I have spent hours on this today and not until now did I find the issue. Thanks as the data usage restriction item when turned off allowed the contacts to sync immediately.
 
Last edited by a moderator:

sjcaro

New member
Aug 15, 2019
2
0
0
Visit site
I have spent hours on this too. Migrated from iphone to Samsung Galaxy Note 10 plus. Exported contacts from iCloud (online), and imported into Google Contacts (online). All contacts where showing in Google contacts online, 70% of the contacts on the Google Contacts app on the phone, and only 50% on the app Samguns contacts.

This worked for me:

1) downloaded, on the phone, the app Google Contacts (more contacts showed on this one, but still a lot missing);

2) Cleared app cache and data, from both Google contacts and Samsung contacts (the app name and Icon are the same, Google is orange, Samsung is blue). Go to Settings > Apps Manager, then swipe to All and choose Contact Sync. Select Clear cache and clear data.

3) Removed google account, and added it again. Go to Settings > Accounts > Google and select the account you’re having issues with. Choose the Remove account option, then go through the setup process one more time.


Check this also. Go to:

Settings > Data usage > Android services > Restrict background data/services. (Make sure this is off).

Then:
Make sure Google Contacts sync is turned on. Go to Settings > Accounts (click on top of it) > Google and select the account you’re using. Make sure Contacts is checked. Again, even though it is, turn it off then on again a few times.
 

Trending Posts

Forum statistics

Threads
942,827
Messages
6,916,073
Members
3,158,669
Latest member
Gennenb