Why can't I sign in into the Google Play Store?

Adriano Raffoul

New member
Aug 4, 2015
Visit site
cant sign in into google play store

HI , i am using a samsung galaxy s4 model SGH-I337.
last week i upgraded to lollipop version, nt sure what version exactly , but since than i have been getting some errors or problems, i fixed the other ones , but now i am stuck with this message: "can't stablish a reliable connection server", when i try to access google play or sign in into my google account.
I have already tried:
1- restart the phone
2- reset the phone 3x (using restore and without )
3- with wi-fi and 4g network
4- i already signed in using my pc , and i have no problem to sign in in my pc , looks like the problem is only with my phone.
5- my phone was rooted , but now it isnt root anymore, i i tried rooted and not rooted.
6- i checked the date , and it is ok , the date is updated.
7- already tyoed on google search for solutions , and none of them fixed my problem (clear cache for most google services, changing some advanced number in my connection, like IP setting to static than changing the DNS1 and DNS2, nothing worked !)
anyone could help me with this error ?


Well-known member
Aug 28, 2013
Visit site
Re: cant sign in into google play store

I also had problems after updating to lollipop, a factory reset solved them