Why is LTE not working anymore?

Nanuzco

New member
Feb 6, 2016
1
0
0
Visit site
I have a pair of LG G2 D800 that I brought in the US and I brought back to Argentina. After upgrading to Lollipop (5.0.2) they were both able to connect to LTE here (Band 4). However, after a few months one of them is still connecting and the other one is not able anymore. It only connects to 2G-3G like if the Band 4 was not active on that specific device anymore. I have compaired configuration as much as I know and I can't find the difference. I have tried using the SIM in a different device and it does bring LTE up. Hence I know the issue is in the phone.

I have tried doing a factory reset, checking every Access Point configuration available from the provider, however it is still not connecting to LTE.

I tried selecting band 4 within the hidden menu (3845#*800#) LTE-Only / Modem Settings / LTE Band Selection and selecting BAND 4 but it just pops up a window that says "FAIL". However, the other LG G2 that connects to LTE is also giving the same message if I tried the same on it.

What can I try? the same phone worked on the same network with the same chip before, and now is not. I need help.

Thanks in advance.
 

Trending Posts

Forum statistics

Threads
943,148
Messages
6,917,519
Members
3,158,847
Latest member
fallingOutOfLoveWfithTech