Why won't wifi stay off?

japark

Well-known member
Feb 15, 2011
151
1
0
Visit site
WiFi won't stay off.

My phone keeps turning WiFi on and connecting when I turned it off. Is there a setting I'm missing to make it honor my choice?
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,715
4,876
113
Visit site
Re: WiFi won't stay off.

Is it turning on even while the phone is asleep? Or is it turning on as soon as you wake the phone up again?

Go to Settings>Wi-fi, tap Menu>Advanced, and uncheck "Scanning always available."
 

japark

Well-known member
Feb 15, 2011
151
1
0
Visit site
Re: WiFi won't stay off.

That option does not appear in WiFi -> menu -> Advanced

WiFi turns itself on whenever I turn it off.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,715
4,876
113
Visit site
Re: WiFi won't stay off.

This is always a bit difficult to figure out, since different devices can have different menu options. How about any kind of wi-fi optimizer? If there's one available, turn it off.
 

ab304945

Well-known member
Dec 20, 2010
1,593
54
0
Visit site
Re: WiFi won't stay off.

Go to settings>more connections> mobile networks>connections optimizer and uncheck it. See if that helps

Posted via the Android Central App
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
Re: WiFi won't stay off.

There are some apps that can do that. I read a similar problem a time ago and the culprit was Avast.

If you have the patience you can check any possible culprit going to settings - apps and have a look at the permissions. It should have one saying "connect and disconnect from WiFi".
 

Javier P

Ambassador
Feb 21, 2014
19,480
3
0
Visit site
Re: WiFi won't stay off.

Just forgot. Check first any anti-theft settings in your apps. That was the problem with Avast.
 

MrJK

New member
Dec 5, 2014
1
0
0
Visit site
Try settings>more settings>mobile networks>automatic connections> then uncheck connection optimizer. Hope this helps. You probably resolved this by now
 

colyn1353

Well-known member
Sep 28, 2014
261
0
0
Visit site
Re: WiFi won't stay off.

That option does not appear in WiFi -> menu -> Advanced

WiFi turns itself on whenever I turn it off.

The correct path with the GS5 is settings-WiFi-tap the 3 dots in the upper right then pick advanced-then untick always allow scanning..
 

japark

Well-known member
Feb 15, 2011
151
1
0
Visit site
Re: WiFi won't stay off.

The correct path with the GS5 is settings-WiFi-tap the 3 dots in the upper right then pick advanced-then untick always allow scanning..

I have tried every setting I can find. Nothing seems to work. I can turn WiFi off, but it will be back on in less than a minute, particularly if I am doing anything which involves data.
 

Kelly Kearns

Well-known member
Jan 10, 2012
8,729
6
0
Visit site
Re: WiFi won't stay off.

I don't see such an app. Why would that help?

It wouldn't help, it causes problems, like turning on WiFi or turning it off, and ignoring the settings you have.

Most carriers, Sprint, Verizon and AT&T include them.

Who is your carrier?
 
Last edited:

Derek Karnes

Member
Dec 8, 2014
6
0
0
Visit site
I, too, have this problem since the update. The problem, I think, is that Quick Connect won't stay off. Even if you kill it, turn it off, force stop it... it keeps coming back, and as soon as it does, the WIFI turns on. I made the mistake of going through Samsung support who talked me into a Factory reset, but the problem still persists.
 

tcn9315

New member
Feb 27, 2015
1
0
0
Visit site
I recently switched from another carrier where I was using a Samsung Galaxy S5 with Lolipop and when I switched I got the same phone and updated it and was having the same issue of WiFi not cutting off. I had turned off the connection optimizer and everything and I could turn off WiFi but in a matter of a few minutes it would be back on and it was frustrating as all get out. I think I have found a fix and I did these simple steps and have been on the mobile network ever since but I can cut WiFi on and off when I want to now.

Start your phone in Safe Mode. To do this restart your phone and when the Samsung logo comes up hold down the volume button. Once it boots (it should say Safe Mode in the bottom left corner) go to Settings>More Networks>Mobile Networks>Connections Optimizer. Once in the connection optimizer if it shows to be off turn it on and then back off or if it is on just turn it off. After doing this restart the phone in normal mode. This worked for me and I hope it will work for ya'll as well.
 

japark

Well-known member
Feb 15, 2011
151
1
0
Visit site
I recently switched from another carrier where I was using a Samsung Galaxy S5 with Lolipop and when I switched I got the same phone and updated it and was having the same issue of WiFi not cutting off. I had turned off the connection optimizer and everything and I could turn off WiFi but in a matter of a few minutes it would be back on and it was frustrating as all get out. I think I have found a fix and I did these simple steps and have been on the mobile network ever since but I can cut WiFi on and off when I want to now.

Start your phone in Safe Mode. To do this restart your phone and when the Samsung logo comes up hold down the volume button. Once it boots (it should say Safe Mode in the bottom left corner) go to Settings>More Networks>Mobile Networks>Connections Optimizer. Once in the connection optimizer if it shows to be off turn it on and then back off or if it is on just turn it off. After doing this restart the phone in normal mode. This worked for me and I hope it will work for ya'll as well.

I tried that and so far it seems to have solved the problem. Thanks!

Update. This helps but does not prevent WiFi from turning itself on.

The only way I can turn it off and keep it off is with MacroDroid. You can create a macro which will turn off WiFi immediately when it turns on, effectively keeping it off.
 
Last edited: