WiFi Automatically enabling itself

Hikyuuri

Member
Jul 1, 2015
7
0
0
Visit site
Hello,

This past weekend, I went to my cabin for the first time with my new S6 Edge. During the drive, I had no Sprint (home) coverage, but there was roaming coverage.

My problem is this. Whenever I roamed, my WiFi would automatically kick in and connect to my GoPro (dash camera). Obviously, my GoPro WiFi does not provide any internet access, so my phone would loose all data connectivity, meaning I don't get text messages or e-mails (I use Google Hangouts, converts texts to data).

I would disable the WiFi on the cellphone from the swipe-down menu, but 1 minute later it would just reactivate itself and connect to my GoPro. I even watched it this by keeping the swipe-down menu open and watched the WiFi button go from gray (disabled) to yellow (enabled) without me touching anything. I eventually disabled the wifi on my GoPro, but this is not ideal because I had another device connected to keep an eye on what it sees. I obviously lost this other device when I turned the wifi off in the gopro.

The wifi would still keep enabling itself, but it would have no network to connect to, so it continued to use my roaming data as expected. However, since the wifi was on, it drained my battery faster, and it would still enable itself whenever I turned it off.

I did disable the Connection Optimizer, verified I had roaming data and voice enabled (Domestic), etc. Is there something else that would force the wifi to become enabled when I don't want it to?

I would also like to point out it does not do this when I am connected to Sprint's network, even if I don't have data on Sprint's network. It only does it when I am roaming.
 

erasat

Well-known member
May 12, 2013
2,590
0
0
Visit site
See in WiFi settings if Smart network switch and Always Allow scanning are on, if they are, turn both of them off.
 

Forum statistics

Threads
943,804
Messages
6,920,147
Members
3,159,242
Latest member
MelmanVT