• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Wifi is always on??

IronCat21

New member
Mar 15, 2015
161
0
0
I've been seeing this for a while now. My phone has been showing that my WiFi has constantly been running, when I turn it off whenever I'm on the road. I'm thinking this is why my battery is draining even when I'm constantly on Battery Saving mode. I doubt it's caused my lollipop since I've hard reset already, and that solved my overheating and messaging problems.

Can anyone help with why my WiFi is always on?

53e0d814b9ebfbcdf8ef8d2b747297be.jpg
 

SpookDroid

Ambassador
Jul 14, 2011
18,842
7
38
Are there any apps that are polling for your location? If you've set your location settings to use WiFi for that, that might be what's causing it...
 

IronCat21

New member
Mar 15, 2015
161
0
0
Nope, I keep my GPS and wifi off when I'm not using it. The only time I have GPS on is when I'm using Waze or something.
 

systemofadown1

New member
Dec 7, 2012
888
0
0
I keep my wifi on pretty much 24 /7 even when I'm not around wifi and it seems to cause little damage to my battery.
I've also noticed that when I click the button to shut it off it will search and reconnect anyway a small while later. I'm sure if you go deep enough into the settings you can disable it and keep it from searching and reconnecting. but I don't think WiFi is really having much of an effect on your battery - looks like cellular signal might be though
 

IronCat21

New member
Mar 15, 2015
161
0
0
Figures, I'm in the middle of nowhere with a signal booster. Is green the good signal or the bad?
 

SpookDroid

Ambassador
Jul 14, 2011
18,842
7
38
Green signal is good, but the yellow and browns are not (and that probably depletes your battery more than WiFi when not connected). And Location Services, when you activate them, it does say that it allows them to turn on WiFi even if the switch is off to get a location reading. That's why I'm wondering if a rogue app is using your WiFi for that constantly. Also your device seems to be awake A LOT. Were you actively using it the whole time? I'm guessing from the Screen Time that you did, but just wondering.
 

IronCat21

New member
Mar 15, 2015
161
0
0
Today, yes, I was watching Netflix all morning. Hmmm okay. I'll look into that. Weird, it shows the worse signal was when I was out.. very odd. I'll check all my settings though. Thanks!
 

systemofadown1

New member
Dec 7, 2012
888
0
0
Excellent point SpookDroid ;)
The phone is awake for almost the full battery graph...
Try running in safe mode & see if an app is causing this (if its not the OP of course)???
 

IronCat21

New member
Mar 15, 2015
161
0
0
I just tried it in safe mode, it's working perfectly now. No wifi is being used. What should I be looking for exactly? Apps that use GPS? I just figured they'd use my data instead...
 

systemofadown1

New member
Dec 7, 2012
888
0
0
Good deal :)
You'll want to start working your way through the 3rd party apps & see which one is causing you the trouble. Take it slowly & you'll find the culprit :)
 

IronCat21

New member
Mar 15, 2015
161
0
0
Question, do they put mobile data under wifi in the battery chart? Whenever I have data turned on, the wifi chart starts charting.
 

systemofadown1

New member
Dec 7, 2012
888
0
0
Are you with Verizon by any chance?
They had an issue where the caller I'd app was causing trouble.
also I think Verizon runs wifi and data together and the phone or certin apps pick up whichever is working best for them at the time.
That could be why you see WiFi as data or vice versa.
 

IronCat21

New member
Mar 15, 2015
161
0
0
Yep I have Verizon, I have every verizon app except verizon messages and voicemail disabled though.
Yep sound like it! Thanks for the help, case closed lol
 

BR34KF4ST

New member
Jun 29, 2014
499
0
0
go to wifi>press the 3 dots menu on top right>press advanced>keep wifi on during sleep turn that off

Posted via the Android Central App