Wifi permanently on

Blessedwalnut

Member
Feb 24, 2015
6
0
0
Visit site
Hi,

I noticed battery drain was quite high today so looked at my usage. I've attached screenshots, but basically I have been on battery since 7 this morning, and wifi has been using battery for all bar 2 mins of this. This is odd as my WiFi has been turned off since 7.30 this morning.

I went in, turned the WiFi on and off again, restarted the phone and then checked the battery stats again, but the 'WiFi has been on for' time just keeps increasing (GSAM app agrees with this). The only way to stop it is to put my phone in airplane mode.

Anyone had anything similar happen or know a way to fix this (not a factory reset!)

Galaxy s7 running 6.0.1 kernel 3.18.14-9519568

Nick

Screenshot_20170103-145039.pngScreenshot_20170103-145046.png
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,191
5,638
113
Visit site
Whoa, that's kind of ridiculous.:-\ Try going to Settings>Privacy>Location>Improve Accuracy, and see if wi-fi scanning is turned on. If so, turn it off. Remember, if the phone asks you if you want to Improve Accuracy, saying yes will turn on GPS as well as wi-fi scanning, so be cautious when you get prompted for this.
 

N4Newbie

Trusted Member
Nov 15, 2012
5,006
1
36
Visit site
Seems to me there is more going on here than meets the eye.

My Wi-Fi is always on and nearly always connected: when at home, when at work, and at least some of the time when I am out and about. I'll bet it is connected 20+ hours per day. And, yes, I have location set to high accuracy all the time.

Still, Wi-Fi never rises to the level of appearing on the battery usage list of my Pixel XL and don't recall it ever appearing with any of my other many devices.

Question: what has your data usage been like? Check the list of apps using Wi-Fi data and see if anything seems not quite right.
 

Almeuit

Moderator Team Leader
Moderator
Apr 17, 2012
32,277
23
38
Visit site
Whoa, that's kind of ridiculous.:-\ Try going to Settings>Privacy>Location>Improve Accuracy, and see if wi-fi scanning is turned on. If so, turn it off. Remember, if the phone asks you if you want to Improve Accuracy, saying yes will turn on GPS as well as wi-fi scanning, so be cautious when you get prompted for this.

This!
 

Trending Posts

Forum statistics

Threads
945,987
Messages
6,928,194
Members
3,160,039
Latest member
tarzanathequeen