Will not connect to wifi with "use packet data"


New member
Mar 14, 2014
Visit site
Hi my phone is a Samsung Galaxy S II Skyrocket from at&T. It will not connect to my home wifi or any wifi. This started last night and it's only my phone. My husband's phone is the same as mine and his has no problems. Wifi is working through out my house as all other tablets and computers are connected. Last night it would try to connect to my wifi then a few seconds later it would kick off saying my wifi not in range and say "connected to null" I've re booted the modem still no luck. I have not updated any apps lately. I spoke to att support this morning and was able to connect to my wifi by shutting off wifi and "use packet data" turning on airplane mode and then turning on wifi. The rep was nice (but was pushing different att apps and storage ect)to backup my phone and will call back Monday to see if that worked. However when got off the phone with her I checked off "use packet data" it started searching for wifi and would get kicked off.We are not due for upgrade until Sept, no insurance, and are out of warrenty. I'm at a loss because my phone will not regnize any wifi when "use data packet" is clicked. Any help or suggestions will gladly be taken.