06-04-2017 06:13 PM
55 123
tools
  1. David Kraft's Avatar
    go to View and uncheck phone and sim.

    default will now be google
    12-12-2012 03:00 PM
  2. Sun Lee's Avatar
    I had this problem after the 4.2.1 update.. contacts I created on the phone did not update to gmail because it was they were stored on the phone.. You need to to to contacts, then hit Menu/Contacts to Display then select your gmail account. Now when you create a contact it defaults to Gmail..
    12-30-2012 05:52 PM
  3. bbsemiaddict's Avatar
    I tried all tips on my HTC ONE X ATT and it only defaults to STORE TO PHONE no matter what I do. Anyone know if it will be fixed in next version of HTC SENSE that comes out with the JELLY BEAN sandwich update? (For HTC ONE X any day now?)
    01-03-2013 03:00 PM
  4. holt1001's Avatar
    Have not found a way to change the default; however, here are three suggestions (2 were already posted)
    1. Enter contact into google contact on computer and let it sync to phone.
    2. Discipline yourself to select gmail account when add a contact on phone
    3. To "move" contact to google contact an use steps below. The process is long, but is a way to transfer contacts digital.
    b. Select Phonebook at top of screen.
    c. Uncheck all options except phone
    d. Open a contact that you wish to save.
    e. Press Menu then Send Contact. Follow the prompts to send to your gmail account.
    f. In Gmail open the email and Import Into Contacts.
    02-15-2013 11:01 PM
  5. Chintan Zangda's Avatar
    Having same problem on my touch 4g as other users mentioned. The only way around to this problem is an app called Go Contacts. While adding a new number this app will ask in which account we would like to store instead of default "phone". Make this app as default for storing contacts and problem is solved. Hope this helps! :-)
    acsurfer likes this.
    02-22-2013 12:50 PM
  6. Jonathan Jung's Avatar
    I finally figured out how to switch default "save contact" from phone to my gmail account. I have a Note2 with the latest android
    Go to
    1) settings
    2) Application Manager
    3) all
    4) scroll down to Phone
    5) Clear Defaults
    exit, exit, exit
    I rebooted... not sure if that was nessasary

    now.... when I save a number from dialer or otherwise
    1) add to contacts
    2) Create contact
    3) now I have a drop down menu (which I didn't have before... only phone) I can pick my gmail account where to save the contact
    4) type in info and save
    it is now in my gmail contacts

    by removing phone defaults I now have that choice again between "phone" and "Skype" when I am trying to call someone. If I select phone and "always" it will not effect my saving default....


    Hope this help... jon
    mositek and Naet like this.
    03-22-2013 11:15 PM
  7. Offbyone's Avatar
    I have a Galaxy Nexus but had the same problem with the wrong Default contact type on a new contact. I went to Settings>Apps>All Apps>Contacts (not contact storage) and cleared the data. This then prompted me to re select the default location when I tried to add a new contact.
    Jonathan Jung likes this.
    03-27-2013 02:09 PM
  8. fender242's Avatar
    Not sure if you got an answer. But I had the same problem and I've solved it.

    1. Go to Contacts, then Display Options. De-select all options except Google account (under "Choose contacts to display").

    2. Enter a new contact, choose Google under "Contact Type". Save contact.

    3. Re-boot Phone.

    Voila! This should work.
    acsurfer and Don Nems like this.
    04-02-2013 09:42 PM
  9. Kieren Black's Avatar
    I finally figured out how to switch default "save contact" from phone to my gmail account. I have a Note2 with the latest android
    Go to
    1) settings
    2) Application Manager
    3) all
    4) scroll down to Phone
    5) Clear Defaults
    exit, exit, exit
    I rebooted... not sure if that was nessasary

    now.... when I save a number from dialer or otherwise
    1) add to contacts
    2) Create contact
    3) now I have a drop down menu (which I didn't have before... only phone) I can pick my gmail account where to save the contact
    4) type in info and save
    it is now in my gmail contacts

    by removing phone defaults I now have that choice again between "phone" and "Skype" when I am trying to call someone. If I select phone and "always" it will not effect my saving default....


    Hope this help... jon
    I have a Galaxy S4 and instead of selecting "Phone" in the list of apps I selected "Contacts" and then cleared defaults
    acsurfer likes this.
    05-25-2013 11:51 PM
  10. Dr Pooja's Avatar
    I finally figured out how to switch default "save contact" from phone to my gmail account. (Take back up of your contacts before doing anything)
    I have S3 and Note 2 with the latest android
    Go to
    1) settings
    2) Application Manager
    3) all
    4) scroll down to contacts
    5) Clear data
    exit, exit, exit
    Now go to contacts ....
    Add new contact you ll get 3 options.
    Select gmail ie google contact.Now when you want to add new contact it ll be stored automatically to google contact ie gmail contact.
    07-18-2013 10:04 PM
  11. Dr Pooja's Avatar
    I finally figured out how to switch default "save contact" from phone to my gmail account.(Take back up of your contacts before doing anything)
    I have S3 and Note 2 with the latest android
    Go to
    1) settings
    2) Application Manager
    3) all
    4) scroll down to contacts
    5) Clear data
    exit, exit, exit
    Now go to contacts ....
    Add new contact you ll get 3 options.
    Select gmail ie google contact.Now when you want to add new contact it ll be stored automatically to google contact ie gmail contact.
    07-18-2013 10:16 PM
  12. Tricia Denning's Avatar
    08-15-2013 01:06 PM
  13. pavel123's Avatar
    Oh thanks a lot, clearing data for contacts app and then creatingnew contact with google type makedit as default storage option in samsun galaxy 4!
    09-17-2013 04:46 PM
  14. Robert S1's Avatar
    Problem:
    Contacts typed on phone do not go to computer gmail contacts.
    Contacts typed on computer gmail contacts go to android.

    Solution.
    First, here is a sensible work process that I use.

    My work process.
    I want my contacts to be stored in my main gmail accounts.
    (The solution will work if instead gmail you use other provider.)
    That is to say, as soon as I type my new contact, it will go
    into gmail contact list.
    Here is how to achieve that.
    On Android do:
    1.
    main | phone | contacts | +new contact | just UNDER the new contact
    there is little triangle that if you touch that, it will be menu
    allowing to select who will be hosting your contacts | I select gmail.
    This way it will configure that any new contacts will be stored in gmail contacts.
    2.
    Then to see the right thing (only gmail contacts), do:
    main | phone | contacts | menu | contacts to display choose gmail only.

    Disclaimer:
    If you want to use SIM to store some contacts and gmail to store other
    contacts my solution is not applicable.
    If you will use my work process, my solution works.
    Note to Android designers of phone app, the triangle is a BAD idea, it should
    be under menu option.
    11-08-2013 04:22 AM
  15. Raphael Kaufmann's Avatar
    That was very helpful and your step by step guideline extremely clear. Thx for that!
    11-21-2013 05:08 AM
  16. Abdullah Nasser's Avatar
    hello all dears
    I have problem in my gmail contacts that when I save any i dont find it in "My contact", I find it in "Other contact"
    my phone Samsung Galaxy with android 2.3.6

    Hopefully I can get some help
    02-07-2014 09:20 PM
  17. alemito's Avatar
    Hi all,
    please let me announce this app that makes exactly this work: move contacts on device to one of your GMAIL accounts.

    https://play.google.com/store/apps/d...e.phone2google

    Best regards
    Ale
    02-28-2014 05:08 PM
  18. Harpreet Singh Pannu's Avatar
    Thanks for the option BUT it does not work.
    04-01-2014 09:18 AM
  19. Convert2's Avatar
    I have a solution - get a Moto X. My Moto X doesn't even have an Contact Type option of Phone. Adding a new contact defaults to Google. I thought all Android phones did this. However, I came across this when my wife just moved from an HTC One X to an LG G2. Neither of those phones has the option to set the default Contact Type for a new contact, and the default is Phone. What a major pain. When transferring contacts to the new phone, I thought no problem, just sync Google contacts, piece of cake, but all of the contacts didn't sync. She didn't realize that every new contact she added in her One X was being added to the phone only and not syncing to Google contacts. At least the One X has a built in solution under Phone Settings, Manage Contacts, you can copy from one account to another. Who designs these feeble contact apps where you can't change the default settings? Ridiculous!
    04-26-2014 02:40 PM
  20. binarysolo123's Avatar
    3 years later and I have this same problem as the original poster. When adding new contacts the default contact type is set to "Phone" and I want to change it to "Google". I have scoured the internet for every possible solution. The one commonly recommended fix is to uncheck the other contact types in the drop down when viewing the list of People, so only "Google" is displayed. I tried that, but I still get "Phone" as the default when adding a new contact. I tried restarting the phone after modifying the drop down fields, but it didn't change anything. I am about to pull my hair out.

    I have an HTC One M8. Android version 4.4.2. HTC Sense version 6.0. Software number 1.55.605.2. Verizon service.

    Please let me know if you know of any fix!!
    acsurfer likes this.
    06-05-2014 04:39 PM
  21. hybucket's Avatar
    Let me add another to this long thread. I have added three new contacts to my CONTACTS (on S3) since I got 4.2.2. They added themselves as "phone" contacts as opposed to "G". Two questions:
    How do I change them to "G" contacts, so they show up on my laptop's GMail?
    How do I change the default to "G", as, when I put first put them in, it did not give me he option of where to put them?
    10-10-2014 09:31 AM
  22. JustJinxed's Avatar
    I ran across an older verizon LG, android version 2.2.2. Have to say none of the tricks worked to change the default storage of new contacts to google. Fairly certain they have picked up on this problem over time and fixed the UI. This phone in particular has a sub system install of "Backup Assistant" which insists that all contacts be saved to the phone by default. Annoying.

    If it wasn't for the fact that someone just gave my aunt this phone, and she really likes the feel of it, I'd tell her to update it. Poor thing won't even handle ICS. *sigh* So for now, our only option is export phone contacts, copy merge all the vcard files into one, and then import them into gmail.
    05-18-2015 01:18 PM
  23. mcefalu's Avatar
    I had the same issue. I finally gave up trying to screw with it and just deleted the contact and added it back in with gmail selected. Who would ever develop something where you couldn't edit the storage location???
    06-09-2015 02:26 PM
  24. hybucket's Avatar
    Makes no sense not to be able to edit once saved..
    I wound up exporting the contacts (whether they were Google or phone or SIM) to GMail on my computer, deleting them on the phone (went to the app and cleared the cache and the data), then let them re-sync to the phone. I just have to be careful when entering a new contact that I change the setting to Google before I save it.
    06-09-2015 04:29 PM
  25. Andrew4096's Avatar
    Makes no sense not to be able to edit once saved..
    I wound up exporting the contacts (whether they were Google or phone or SIM) to GMail on my computer, deleting them on the phone (went to the app and cleared the cache and the data), then let them re-sync to the phone. I just have to be careful when entering a new contact that I change the setting to Google before I save it.
    When performing this operation, contacts should be exported in vCard (.vcf) format to preserve street addresses, notes and thumbnail images. If you save to SIM and expect to get your data back, you'll cry a river of tears: Saving to SIM strips everything except the Name and Primary Phone Number.

    When re-importing from a vCard file, the phone should give you the option of which account you want to use — Phone, Gmail, etc. It won't let you use read-only accounts, such as Skype. Select Gmail and all imported contacts will get synchronized with your Gmail Contacts. In the alternative, create all contacts in Gmail Contacts with a browser running on a laptop or desktop machine. That way, you'll save your eyes and every contact you create will be a Gmail contact after it is synchronized with your phone.
    11-16-2015 03:29 PM
55 123
LINK TO POST COPIED TO CLIPBOARD