08-13-2013 04:28 PM
31 12
  1. bespinct's Avatar
    Is it possible to start Google Now from Aircast (say, by a long button press) or are you required to tap the phone for activating Google Now?
    I won't be able to check until later in the week, but will let you know if no one else has responded.


    Sent from my Galaxy Nexus using Tapatalk 2
    08-05-2012 06:54 AM
  2. oraphus's Avatar
    i have an evo3d.. i haven't figured out how to skip songs using the Belkin aircast.

    I tried using both winamp and native music player. Double clicking the belkin just pauses. can anyone help?
    08-08-2012 01:37 PM
  3. mrwiltonchan's Avatar
    Did you ever find out if Google now or some type of voice command works on the Belkin on the new Android phones? I know you can hold the button to have SIRI come up with an Iphone, but what about our Androids?

    Thank you for the post as well so far, great stuff!

    Now I am looking between the Belkin or the GOgroove FlexSMART X2 ADVANCED as it is cheaper, has the same features plus an FM transmitter. You do give up the button/microphone extension peice that can be connected almost anywhere on your car that the cord can reach.

    11-27-2012 06:12 PM
  4. bespinct's Avatar
    I was never able to get Google now to work using the mic/sync button. I often have my phone in a mount and it's easy to get into Google Now without taking my eyes from the road.

    I absolutely love that a device so cheap gives me an option that would have been part of a package costing thousands of dollars. I haven't had any problems or odd behavior.


    Sent from my HTC6435LVW using Tapatalk 2
    11-28-2012 10:45 PM
  5. k9incredible's Avatar
    08-13-2013 04:10 PM
  6. k9incredible's Avatar
    Re: [Review] Belkin Aircast Auto bluetooth car gateway
    I bought this Belkin Aircast and love it. Works great for music. I am having an issue with the phone feature.
    The phone will not work at all unless I do the following:
    I need to go into Network settings\BlueTooth Settings\carAudio Connect device (that is the air cast)\options\profiles, then remove the check for Use for phone audio exit out then go back to that setting and replace the same check for Use for phone audio.

    I need to do this every time the Air cast is powered up in the car.

    Tried these and they do not work: Restarting the Bluetooth on the phone, reboot the phone, unpair then pair the device.
    For now I put a short cut to the profile check mark setting but it is annoying.

    I have a Droid incredible 1, any ideas???
    08-13-2013 04:28 PM
31 12