1. AC Question's Avatar
    I have the T-Mobile version of Galaxy S4, purchased July 2013, stock ROM, latest update.

    Recently, while connected to the charger, the charging icon showing on the screen, the battery percentage number goes down, until it finally runs out of power. Not only does it not charge while charging, but the power depletes.

    I have tried it with different chargers and cords, same problem, so the issue clearly is in the S4 itself.

    Fortunately I have an external battery charger and extra batteries, and that is the only way I can keep my phone running now. (The problem occurs with different batteries too, so the issue is clearly in the phone.)

    What can be causing this problem? Any way I can fix it? (Of course it is out of warranty, so send to warranty repair is not an option.)

    Thanks in advance for your help.
    11-21-2015 03:18 PM
  2. belodion's Avatar
    It could be a dirty or damaged connector inside the USB port, among other possibilities.
    11-21-2015 04:17 PM

Similar Threads

  1. Dying battery, dying phone, or something else?
    By ubonlad in forum Google Nexus 5
    Replies: 6
    Last Post: 12-25-2015, 04:07 AM
  2. Flat Battery Cover??
    By Notrega in forum Samsung Galaxy Note 4 Accessories
    Replies: 1
    Last Post: 11-22-2015, 08:43 PM
  3. Replies: 1
    Last Post: 11-21-2015, 02:24 PM
  4. Phone Keeps Losing Powere Even On Charge
    By THE Lot Lenore in forum Batteries
    Replies: 1
    Last Post: 11-21-2015, 01:39 PM
  5. Replies: 0
    Last Post: 11-21-2015, 09:40 AM
LINK TO POST COPIED TO CLIPBOARD