Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  

    Default CM7 connection issue

    I have been experiencing an issue with CM7 (any version that I have flashed up to 2/16 nightly) where my connections have been...lacking. When I unlock my phone every once and a while my wifi and 3g data will not connect for a while, then suddenly will snap back. The status bar shows the connections as being white when they are not working (usually blue when working). I have not seen a post about this problem as far as I have seen. Anyone else experiencing this issue? Is there a work around or fix for it?

    I'm leaving a pic to show what the status bar looks like.

    CM7 connection issue-screenshot-1329505299680.png
  2. #2  

    Default

    Have you actually tried using mobile internet services? The color has nothing to do with whether or not your connected, it only tells you if your connected and synced through google services.

    Sent from my SPH-D700 using Tapatalk
  3. Thread Author  Thread Author    #3  

    Default Re: CM7 connection issue

    Quote Originally Posted by Zeinzu View Post
    Have you actually tried using mobile internet services? The color has nothing to do with whether or not your connected, it only tells you if your connected and synced through google services.

    Sent from my SPH-D700 using Tapatalk
    Actually, anytime those are white and not blue, I get "no connection" errors in every app that uses data and my phone won't dial out. Facebook pops up as, "no connection try again", the browser app has no connection. Sometimes it goes blue right away and I can use my apps, but sometimes it stays white and the apps that use data are useless unti it turns blue again.
  4. #4  

    Default

    The color still only indicates sync. I'm not denying however that your having connection issues.

    Sent from my SPH-D700 using Tapatalk
  5. #5  
    ZombieHacks Avatar

    Posts
    24 Posts
    ROM
    CM7 w/ ChevyNo1's 1.1 LV

    Default Re: CM7 connection issue

    When you lock your phone, the default Wi-Fi policy is to turn off, so when you unlock your phone it has to reconnect to the router. The time it takes for your device to authenticate, lease an IP, and ping Google's servers is the time it takes to turn your WiFi icon from white to blue. You can change this by going to Settings>Wireless & Networks>Wi-Fi Settings, pressing the menu button>Advanced and changing WiFi sleep policy to Never if you're around Wi-Fi the majority of the day. At least change it to Never when plugged in, to help save on mobile data costs.

    I have a Moto Droid running CM7 that I use as a portable media player w/o cell service, so I use an Airplane Mode Wi-Fi tool to keep my cell radio off (HUGE battery savings!) and leave my Wi-Fi on. When my Wi-Fi icon turns white, I also lose all connectivity. Even if you don't want to change your Wi-Fi sleep policy, next time the icon turns white and won't change you can fix it 100% of the time by toggling your Wi-Fi off and then back on.

    If your Wi-Fi icon stays white, it means that your phone can't communicate with Google's servers over your Wi-Fi connection. Check your other computers for internet connectivity. Let me know if any of this helps!
    Last edited by ZombieHack; 02-26-2012 at 02:54 PM. Reason: Clarification and phixing my gra-ma-mar.
    ZombieHacks Android Adventures
    http://zombiehackaa.blogspot.com/

Posting Permissions

B