Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
  1. Thread Author  Thread Author    #1  
    emoeskaite's Avatar

    Posts
    109 Posts
    Global Posts
    113 Global Posts
    ROM
    Android 4.2.1

    Default Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    Hey,
    I bought two Galaxy Nexuses, one for me, one for my mom. When I first started using my phone, the HSPA+ network worked pretty nice but after some time (like a week) it started doing crap. Both of them. We are using them with Monthly4G $70 plans from TMO. Simply, the internet works for about 1-2 minutes once the H icon activates. After that time it can't open any website, maps or anything that needs connection, even though the blue H icon with two arrows is still on. The only way to make it work for another 1-2 mins is to either close everything that uses connection and wait until the icon changes to 3G or reset the phone. I called both T-Mobile and Google but TMO says they can't help me if this is a non-T-Mobile device and they don't guarantee any speeds for such phones, Google says the phone is OK and call TMO. We live in Chicago, I've tried cruising around to get connected to different towers but it's still the same. I tried performing master reset, no help. Anybody know how to help?? I spent $800 on these things and now I don't even have internet on both of them....

    Sent from my Galaxy Nexus using Android Central Forums
  2. #2  
    npark2012's Avatar

    Posts
    615 Posts
    ROM
    STOCK

    Default Re: Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    Quote Originally Posted by emoeskaite View Post
    Hey,
    I bought two Galaxy Nexuses, one for me, one for my mom. When I first started using my phone, the HSPA+ network worked pretty nice but after some time (like a week) it started doing crap. Both of them. We are using them with Monthly4G $70 plans from TMO. Simply, the internet works for about 1-2 minutes once the H icon activates. After that time it can't open any website, maps or anything that needs connection, even though the blue H icon with two arrows is still on. The only way to make it work for another 1-2 mins is to either close everything that uses connection and wait until the icon changes to 3G or reset the phone. I called both T-Mobile and Google but TMO says they can't help me if this is a non-T-Mobile device and they don't guarantee any speeds for such phones, Google says the phone is OK and call TMO. We live in Chicago, I've tried cruising around to get connected to different towers but it's still the same. I tried performing master reset, no help. Anybody know how to help?? I spent $800 on these things and now I don't even have internet on both of them....

    Sent from my Galaxy Nexus using Android Central Forums
    I'm from Chicago too and I have the Galaxy nexus with Tmobile. Mine works just fine. I'm not entirely sure what's wrong with yours but have you tried turning the phone off then take the battery out, leave it out for a minute. Take the sim card out and put it back in then put the battery back in and turn it on again. See if that helped.
    Thanked by:
  3. Thread Author  Thread Author    #3  
    emoeskaite's Avatar

    Posts
    109 Posts
    Global Posts
    113 Global Posts
    ROM
    Android 4.2.1

    Default Re: Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    Yeah, I have. It helps for two minutes or so and then the internet dies. It's strange that it happens to both of my phones, both with defferent SIM cards..... What area are you from? Mayhe it's just my neighborhood's towers....

    Sent from my Galaxy Nexus using Android Central Forums
  4. #4  

    Default Re: Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    It's a T-Mobile problem. If you can 100% confirm your APN settings are correct, you need to go into a T-Mobile store and have them repovision your SIM or give you a new SIM card(s).

    It doesn't matter that you have a Google (and not T-Mobile) device, T-Mobile has to support the SIM they sold. They should have no problem giving you a new SIM for the account(s).

    You're right though, calling Google won't help because this is 99% likely not a hardware issue. Google's not at all liable for the issues you have with a service provider.
    LG Nexus 5 / Galaxy S5 // T-Mobile / AT&T
    Thanked by:
  5. #5  

    Default Re: Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    I am in the Chicago area as well but I don't have problem no matter where I go.

    Did you call TMobile to update your IMEI numbers for your accounts?
    Thanked by:
  6. Thread Author  Thread Author    #6  
    emoeskaite's Avatar

    Posts
    109 Posts
    Global Posts
    113 Global Posts
    ROM
    Android 4.2.1

    Default Re: Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    Ok, it must be just one tower. I moved like 2 miles away from where I lived and now my internet works well again. However when I go back to the previous place, it doesn't again... I reported that to morons from CS but they say their towers are OK. My mom still lives there and has got the issues.

    Sent from my Galaxy Nexus using Android Central Forums
  7. #7  

    Default Re: Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    Could be related to the spectrum reform and network modernization. Once all the cell sites are updated you should have better service than ever. Or you could just be in a weak spot. All carriers have these.

    Sent from my Nexus 7 using Tapatalk 2
  8. #8  

    Default Re: Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    I solved the T-Mobile (Chicago) "spotty" and irregular data problem by getting my T-Mobile phone unlocked. I now have an AT&T sim in my (T-Mobile) phone and data is much more reliable.
  9. #9  

    Default Re: Help! Bought 2 phones and T-Mobile's HSPA+ barely works!

    Quote Originally Posted by endofdays View Post
    I solved the T-Mobile (Chicago) "spotty" and irregular data problem by getting my T-Mobile phone unlocked. I now have an AT&T sim in my (T-Mobile) phone and data is much more reliable.
    How is this possibly of any help to someone with a Galaxy Nexus phone on T-Mobile? You are talking about a different phone and network.
    Pat

    Galaxy Nexus 10 - stock KitKat 4.4.4
    Galaxy Nexus 7 (2nd Generation) - stock KitKat 4.4.4
    Chromecast
    Nexus 5 - stock KitKat 4.4.4
    Thanked by:

Similar Threads

  1. HELP!! Bought Rooted Virgin Mobile phone
    By itsavasmommy in forum General Help and How To
    Replies: 11
    Last Post: 08-28-2012, 11:08 PM
  2. Replies: 8
    Last Post: 07-09-2012, 01:18 AM
  3. Help! Started phone and accounts/settings are gone
    By 6tr6tr in forum Sprint Nexus S 4G
    Replies: 0
    Last Post: 07-25-2011, 05:59 PM
  4. Need Help, setting phone back to facorty default still not working....
    By gbreeze in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 15
    Last Post: 12-22-2010, 11:30 PM
  5. HELP! rooted phone and dont know what to do.
    By tomiknockers in forum HTC Droid Eris Rooting, ROMs, and Hacking
    Replies: 1
    Last Post: 12-02-2010, 08:09 AM

Posting Permissions