Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Default Issue's with Samsung Galaxy S3 charging

    Hello Everyone,

    I have a S3 I9300 with the latest Jelly Bean upgraded software and fully updated phone. Until last week everything was fine and my phone was getting properly charged to 100% in 2 hours so.
    But from last 5 days it is hardly getting charged even 50% in the same time. Moreover the larger issue is if my Data (3G) is on, and phone is plugged, it does not charge at all. I mean 1 % in like 15-20 minutes.
    Moreover if the data is off it still takes 4 hours or so to get fully charged.
    I sensed a battery issue and went to service center to get it checked but they confirmed that the battery is perfectly fine. I am not sure what else should i try?
    Could it be a software driver issue? The charging pin is not lose either.

    Let me know what else should I try or if you need any other detail.

    Looking to hear some solution soon.
    Thank You.

  2. #2  

    Default Re: Issue's with Samsung Galaxy S3 charging

    Had a similar issue with my old S3 where the charging cable itself was getting worn internally, causing phone to not charge properly. If you have a replacement cable, try that first. It can still show charging, as mine did, but it just wasn't getting the job done.

Similar Threads

  1. Galaxy S4 Mini: Screen keeps turning back on!
    By Andrew Russell1 in forum Samsung Galaxy S4 Mini
    Replies: 15
    Last Post: 04-16-2015, 08:58 AM
  2. Hong Kong 2014 edition 4G Galaxy Note 10.1 registration problem
    By framncru in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 8
    Last Post: 03-23-2015, 09:48 PM
  3. Replies: 1
    Last Post: 04-18-2014, 05:59 AM
  4. Can't disable lock screen with 4.42. Anyone know how?
    By nneptune in forum AT&T HTC One
    Replies: 8
    Last Post: 04-14-2014, 11:10 AM
  5. Charging two devices from one plug
    By Sam12Ash in forum General Help and How To
    Replies: 3
    Last Post: 02-24-2014, 10:16 AM

Posting Permissions