10-18-2018 11:41 AM
108 ... 2345
tools
  1. Al Borland's Avatar

    If this is really the fix, then might it be easy for Google to add code for a setting to turn off Doze?
    Lol, doze is their baby and in my opinion the chance they would give users a way to disable is minuscule. See the instructions to developers on this link. It would be up to the OEM/Carrier to give users a simple fix like a simple toggle to disable.

    https://developer.android.com/traini...e/doze-standby
    10-03-2018 02:42 PM
  2. Will_T's Avatar
    See the instructions to developers on this link.
    https://developer.android.com/traini...e/doze-standby
    Wow! That is exactly what is causing the issue and explains why notifications are delayed but eventually do come through. BUT, you would have to wonder how Google engineers use their phones to have them think this is OK. To put in place a lock that may save a little battery life, but prevents people from getting timely notifications of home security system alerts, missed phone calls, emails, text messages, etc. etc. seems very draconian.

    edit: By the way, the reference by Google at that link to the phone needing to be screen off and "stationary" to enter Doze mode, is not what I experience. My phone goes into Doze mode shortly after the screen times out even when in my pocket on a hike or working in the garden, times when it is certainly not stationary.

    FWIW, today was my first full day with the fix implemented. I used the phone normally, even having a few hours in and out of service so some apps trying repeatedly to do their thing before getting through. Watched a few videos, made phone calls, texts, emails, LOTS if camera use, etc. Phone was unplugged at about 7:30 am and it is now 9pm and the battery is at 77%. So I don't think I have noticed any increase in battery use from disabling Doze.
    10-03-2018 10:58 PM
  3. J Dubbs's Avatar
    Wow! That is exactly what is causing the issue and explains why notifications are delayed but eventually do come through. BUT, you would have to wonder how Google engineers use their phones to have them think this is OK. To put in place a lock that may save a little battery life, but prevents people from getting timely notifications of home security system alerts, missed phone calls, emails, text messages, etc. etc. seems very draconian.

    edit: By the way, the reference by Google at that link to the phone needing to be screen off and "stationary" to enter Doze mode, is not what I experience. My phone goes into Doze mode shortly after the screen times out even when in my pocket on a hike or working in the garden, times when it is certainly not stationary.

    FWIW, today was my first full day with the fix implemented. I used the phone normally, even having a few hours in and out of service so some apps trying repeatedly to do their thing before getting through. Watched a few videos, made phone calls, texts, emails, LOTS if camera use, etc. Phone was unplugged at about 7:30 am and it is now 9pm and the battery is at 77%. So I don't think I have noticed any increase in battery use from disabling Doze.
    In marshmallow was the first implementation of doze, it wouldn't go into doze until the screen was off and the phone was stationary for a certain length of time...... it worked amazingly..... extremely good battery life without messing anything up. In nougat they mentioned they were going to implement a "doze on the go" feature to help battery life while you were moving. That's when I knew the troubles were starting. With Oreo and Pie they just kept increasing the "doze on the go" parameters until we're where we are now

    Shutting down the ultra aggressive doze in Pie may just be taking you back to the marshmallow version...... which was by far the best ;-)

    What I do find interesting is that my og pixel (non XL) is working perfectly with all notifications on Pie..... it seems like this is mostly affecting pixel 2's.
    10-04-2018 12:14 AM
  4. Will_T's Avatar
    What I do find interesting is that my og pixel (non XL) is working perfectly with all notifications on Pie..... it seems like this is mostly affecting pixel 2's.
    That is an interesting history. I do wonder about this last part though. Given what the issue seems to be, how could it possibly be phone model specific?

    In any case, it won't really be resolved until we have a better option to turn Doze off... either in Android itself, or with an app or widget.
    J Dubbs likes this.
    10-04-2018 12:32 AM
  5. wvigotty's Avatar
    I have a 1 month old Samsung Galaxy S9+ from T-Mobile and it's having this problem. I believe the version I'm on is Oreo or 8.0. I just switched from Microsoft phones, so I'm not that familiar with the phone or OS yet. What I can tell you is that I applied Al's fix and it's working perfectly now. Thanks Al.
    10-04-2018 12:44 AM
  6. DustBow's Avatar
    It's definitely a Google/Android issue related to Doze and I think it's something that arrived via some other update besides a security patch or OS upgrade. I have a Pixel 2 was on Oreo and the last security patch was in July, then they started pushing the Pie upgrade out. I didn't upgrade to Pie until 2 weeks ago.
    I noticed the notifications issue at the end of August/early September - long after my last security patch and well before I upgraded to Pie (which I was hoping would fix the issue but didn't).

    I don't know enough about phones & code and all of the "background apps & systems" that get updated thru the Play Store, but it had to be something related to that. At least on my end.

    I just wonder if this is a bug that is only affecting certain people or if it's more widespread and people simply do not realize it's affecting them and they are getting some emails much later than they should.
    10-04-2018 08:24 AM
  7. Al Borland's Avatar
    ... I think it's something that arrived via some other update besides a security patch or OS upgrade.
    Your observation mirrors my case. It made its way onto my S8 with Nougat 7.0 which is on the Aug 2017 security patch through some other type of update that I couldn't prevent. Some other google app, system file, or Samsung OS/app update.

    Google's GMail Help forum is littered with complaints about delayed notifications. They are clueless about what the problem is and are doing their best to shut down the complaining without actually resolving the base problem.

    It is some seriously dorked up code when it creates a problem, then the adb "fix" reveals that the intended feature Doze, doesn't even do what it is intended to do. My battery life has improved from what was normally 1% drain per hour to .6% drain per hour without doze! Go figure.....
    10-04-2018 08:41 AM
  8. Will_T's Avatar
    OK, so now this is a as easy as I think it can get until there is an option within Android to just switch off Doze mode.

    I made a .bat file with the text below in it. Then I changed the default USB option on my phone to file transfer. (In Developer Options.) Finally, I moved the ADB files and that .bat file to the same folder on my desktop. Now when I plug in my phone all I need to do is double click the .bat file and it is done!

    echo off
    adb devices
    adb shell dumpsys deviceidle disable
    pause
    10-04-2018 02:13 PM
  9. DustBow's Avatar
    Well I attempted to do this but my Pixel 2 won't even connect to my laptop....only thing it does is charge...tried turning USB debugging on and off, tried reboots, tried 2 different cables.

    I used to really like this phone
    10-04-2018 06:37 PM
  10. Al Borland's Avatar
    Well I attempted to do this but my Pixel 2 won't even connect to my laptop....only thing it does is charge...tried turning USB debugging on and off, tried reboots, tried 2 different cables.

    I used to really like this phone
    After you make the connection between your phone and the computer, pull down the notification view at the top of your phone. It should have a line about connecting to charge, or something like that. Click on it, and change it to the file transfer option.

    If you don't have this showing, then you need to install the drivers to your computer for making a file transfer between your computer and phone.

    https://support.google.com/pixelphone/answer/2840804
    10-05-2018 08:11 AM
  11. Al Borland's Avatar
    After you make the connection between your phone and the computer, pull down the notification view at the top of your phone. It should have a line about connecting to charge, or something like that. Click on it, and change it to the file transfer option.

    If you don't have this showing, then you need to install the drivers to your computer for making a file transfer between your computer and phone.

    https://support.google.com/pixelphone/answer/2840804
    10-05-2018 08:22 AM
  12. DustBow's Avatar
    Yeah, I don't even get that notification regarding USB, it just starts to charge....I did download some Drivers but maybe they are not the right ones. Did some searching and this appears to be yet another common issue, especially since Pie. Apparently the phones are really picky about cables, they don't like USB 3.0 ports, etc. Quite a jigsaw puzzle to piece together.
    J Dubbs likes this.
    10-05-2018 08:26 AM
  13. Will_T's Avatar
    Yeah, I don't even get that notification regarding USB, it just starts to charge....
    Yes, First time I connected I had this issue. Once connected, (not before), after it just starts charging, as Al said, you need to open the settings on your phone. Go to the "Connected Devices" tab. Then under currently connected you will see it says "USB Charging this device". Click that. Below there is a radio button for "File Transfer". Click that and you should be good to go.
    10-05-2018 11:39 AM
  14. Bladet's Avatar
    Yeah, I don't even get that notification regarding USB, it just starts to charge....I did download some Drivers but maybe they are not the right ones. Did some searching and this appears to be yet another common issue, especially since Pie. Apparently the phones are really picky about cables, they don't like USB 3.0 ports, etc. Quite a jigsaw puzzle to piece together.
    I had same problem. It wouldnt work with my usb3 cables so I got the cheapest usb to usb-c cable from IKEA! and then it worked.
    10-05-2018 01:03 PM
  15. DustBow's Avatar
    Nothing even shows up under "connected devices" and all USB options are grayed out while connected b/c phone thinks it is in "charging only" mode
    10-05-2018 01:07 PM
  16. DustBow's Avatar
    I had same problem. It wouldnt work with my usb3 cables so I got the cheapest usb to usb-c cable from IKEA! and then it worked.
    Which is exactly the opposite of what Google was telling us to do when USB-C / USB-PD became the new standard - remember all the worries your cables being certified and rated highly enough for charging safely and properly?
    10-05-2018 01:15 PM
  17. Will_T's Avatar
    Nothing even shows up under "connected devices" and all USB options are grayed out while connected b/c phone thinks it is in "charging only" mode
    I see, just as if you had plugged it into a wall charger, not your computer. I have only a regular USB port on my laptop available so I also use a USB to USBc cable.
    10-05-2018 04:15 PM
  18. DustBow's Avatar
    Went to Office Depot and bought a USB-A 2.0 to USB-C cable....still no luck.
    And I also noticed my USB-C to 3.5 adapter dongle still doesn't work, which was something they said was fixed in Pie.

    Tried cleaning out the port, definitely had some dirt on there but still nothing working.

    Even when it temporarily recognizes the dongle is plugged in, the phone just thinks it is some kind of charging device....
    10-06-2018 11:09 AM
  19. Will_T's Avatar
    Just an update on battery life now many days into this fix. I know it seems impossible, but if anything, I think my battery life is better now with Doze off. At the very least it has made no difference from what I was getting before. It really takes a lot of intense usage to get my battery below 75% by the end of the day. Normally it is unplugged around 8am and plugged in at about 11pm. I do all the normal talking, video, browsing, various apps including mapping and gps stuff. I am sure I don't use the phone as much as some, but it is definitely not light usage. I think I saw 67% once recently, but never less.
    10-10-2018 01:07 PM
  20. DustBow's Avatar
    Good to know. I bit the bullet & did a full factory reset the other day and it didn't solve the issue for me & Gmail notifications.
    I'm in the process of getting a replacement Pixel 2 since I've now realized I also have a bad USB C port. It will be interesting to see if the new phone works once I get it set up... But as long as the USB C port works properly, it's good to know I can just disable Doze without any issues. It sounds like we have similar daily usage - my battery never gets too low during a work day unless I'm streaming music & podcasts for 8 straight hours over Bluetooth
    10-10-2018 01:23 PM
  21. Bladet's Avatar
    I recently got an system update and hoped for the best....but still same problem.

    Back to running

    Code:
    adb shell dumpsys deviceidle disable
    10-11-2018 01:55 PM
  22. J Dubbs's Avatar
    I've tested out all my notifications except email, everything's coming through when it's supposed to..... I do now suspect my emails are being delayed though, I'm going to test that out today. I just received the October update, curious to see if that changed anything.

    If there's delayed email notifications, it's definitely an email/pie issue that Google needs to address. Like somebody else mentioned though, delayed emails could definitely slip under most folks radar, me included :O
    10-11-2018 02:11 PM
  23. J Dubbs's Avatar
    Well I let my pixel 1 sit unused and undisturbed for probably around an hour, then sent it an email, it took probably around 20 minutes before the phone notified me that it had received it. Honestly I was expecting it to receive it almost immediately...... but I've never actually done that test on a phone before, so I have nothing to compare it to.

    I do believe there's an option in the email app settings where you can change how often it checks for new mail. I know some of you weren't getting ANY notifications until you woke your phone up..... that's a serious problem, and I hope Google is working on a fix pronto :O

    The only thing I did different with my phone than most of you is during the setup process for Pie when it asked for a fingerprint or pin to lock the phone I skipped that process because I don't lock my phones anymore...... I had too many issues in the past with locked phones and things not working right. I'm glad I didn't lock this one either lol.
    10-11-2018 11:17 PM
  24. Will_T's Avatar
    I know some of you weren't getting ANY notifications until you woke your phone up.....
    Actually I think most are like I was where notifications were delayed until the next time the phone woke itself out of Doze Mode periodically. But yes, if I woke the phone up before the next Doze off trip by Pie, then notifications came through then.

    Since I have had Doze turned off with the command file, things have been perfect. Notifications come through immediately instead of only every 15 or 20 minutes or longer. And no it does not seem like it is a bug. As shown in the link provided above, it is a "feature" that Google coded in to make the battery last longer. And yes in theory that may work, but at the expense of a phone that does not let you know about any alerts, notifications, texts, emails, etc. etc. except for the couple of times per hour Doze turns itself off to allow them through. Here is that link again for anyone who missed it above.
    10-14-2018 02:33 AM
  25. J Dubbs's Avatar
    Thanks Will that was a very informative link ;-) I did notice that was for app developers, the core built in Android apps like texts and emails should already come designed to work properly through doze. I get text messages instantly regardless of how long my phones been idle, in fact the only delayed notification I get is email...... and the email app is set to check in for new mail at certain predetermined times, I've looked at the settings before but don't remember what the default setting was.

    Not getting any notifications at all until the phone is woken up is a bug though, either in the current version of pie itself, or some kind of interaction between certain phones and there configurations with pie. Not all phones are doing it, but it's definitely something that Google needs to be aware of....... although I'm sure they're getting plenty of feedback on it lol.
    You shouldn't have to run code to get your phone to work normally.

    Although that article explains why Fitbit is having so much trouble getting their app to work reliably on pie. I should send them the link ;-)
    10-14-2018 06:56 AM
108 ... 2345

Similar Threads

  1. Why am I not receiving all of my messages?
    By Android Central Question in forum Android Pie
    Replies: 3
    Last Post: 09-10-2018, 05:58 AM
  2. Replies: 1
    Last Post: 08-21-2018, 02:21 PM
  3. Why am I not receiving all of my messages?
    By Android Central Question in forum Ask a Question
    Replies: 0
    Last Post: 08-20-2018, 12:39 PM
  4. Replies: 1
    Last Post: 08-20-2018, 11:19 AM
  5. Q: Yahoo mail notifications and Pie
    By donaldmd13 in forum Google Pixel & Pixel XL
    Replies: 0
    Last Post: 08-20-2018, 09:50 AM
LINK TO POST COPIED TO CLIPBOARD