02-07-2022 08:46 AM
117 123 ...
tools
  1. Davidoo's Avatar
    I have a 6 Pro from Verizon. Every time I restart I get the following notification. "Speech services by Google downloading English (US) update, waiting for network connection."

    Of course I'm on the Verizon network and the download never starts. My first thought was that something was set to only download over wifi, so I went to Google settings and changed the Mobile data and Messaging setting to wifi and cellular under Data Management. No change. If I switch to wifi, the notification goes away, like it finished the download, but on restart the message comes back.

    Anyone else getting this notification it have any ideas how to make it finish the download?
    11-01-2021 10:43 AM
  2. B. Diddy's Avatar
    BEFORE YOU POST ABOUT THIS ISSUE, please read this article for possible solutions: https://www.followchain.org/download...g-for-network/. If that doesn't help, then read through this thread to see if any of the other various solutions help.
  3. Climb14er's Avatar
    Yes, same experience on VZ. Changed the internet setting to get the stuck download to stop.
    Stacey Reyes likes this.
    11-01-2021 11:17 AM
  4. Scott337's Avatar
    Same here, also on Verizon and tried letting it run on cell data and WiFi and it stayed stuck most of the day yesterday. I killed the process and it has not come back.
    11-01-2021 12:10 PM
  5. Davidoo's Avatar
    I may have found a fix for this. I went into the actual Google Play Store settings by tapping the circle in the upper right with my Google profile photo in it. In that Settings menu there are Network Preferences. They were all set to download over wifi only. I switched them all to over any network, restarted, then I saw the notice pop up briefly then go away. I restarted again to be sure and it hasn't come back since. That still doesn't explain why it wouldn't go away when I switched to wifi before. If I get the notification again I'll update here.
    Scott337 and androidlvr77 like this.
    11-01-2021 01:05 PM
  6. Gold_Coast's Avatar
    Thanks Davidoo ... identical problem here on Pixel 6 Pro (not on Verizon network ... I'm on Telstra network in Australia.) Your fix in Google Play settings seems to have fixed it for me. Good job.
    11-04-2021 06:34 PM
  7. fotyc's Avatar
    My settings were already set to allow downloads using mobile data and yet this zombie download starts every day when I turn on my phone. If I enable wifi in an attempt to get it to proceed, it disappears. Yet there is no available update I can download manually, also I can't uninstall and reinstall. Has anyone found any other solutions for this annoyance? ATT user in US here.
    11-20-2021 11:08 AM
  8. findingitnecessary's Avatar
    I found the solution. There is a separate setting for wifi/cellular download for speech services, from the Google play store wifi/cellular download.

    Search "digital assistant app" in the settings search bar. Both gear icons in this menu, one at the top for which assistant is set for your device, and the bottom gear for speech services, both have options to change download via wifi/cellular.

    "Default digital assistant app" gear icon, then "offline speech recognition" midway down, then "auto-update" tab on far right side.

    "Voice input" "Speech services by Google" gear icon, then "auto update languages."
    fotyc likes this.
    12-01-2021 11:16 AM
  9. fotyc's Avatar
    That's it! It's the SECOND gear icon, the bottom gear for speech services, that conceals the option to download over cellular.
    My zombie eventually seems to have died but at least now I have the settings right for when the next update happens.
    12-04-2021 12:22 PM
  10. Harley Hiebert's Avatar
    I found the solution. There is a separate setting for wifi/cellular download for speech services, from the Google play store wifi/cellular download.

    Search "digital assistant app" in the settings search bar. Both gear icons in this menu, one at the top for which assistant is set for your device, and the bottom gear for speech services, both have options to change download via wifi/cellular.

    "Default digital assistant app" gear icon, then "offline speech recognition" midway down, then "auto-update" tab on far right side.

    "Voice input" "Speech services by Google" gear icon, then "auto update languages."
    I can't find the search in my settings on my Google play store
    12-05-2021 09:24 AM
  11. B. Diddy's Avatar
    I can't find the search in my settings on my Google play store
    Welcome to Android Central! I believe findingitnecessary meant that the option is in the system settings. Go to Settings>Apps>Default Apps>Digital Assistant Apps, then tap the gear icon next to Voice Input. You can find the Auto Update Languages option there.
    12-05-2021 12:46 PM
  12. RO IHU's Avatar
    Welcome to Android Central! I believe findingitnecessary meant that the option is in the system settings. Go to Settings>Apps>Default Apps>Digital Assistant Apps, then tap the gear icon next to Voice Input. You can find the Auto Update Languages option there.
    My phone doesn't have "Default Apps" there.
    01-07-2022 02:06 AM
  13. B. Diddy's Avatar
    Welcome to Android Central! You have a Pixel 6 as well?
    01-07-2022 02:15 AM
  14. RO IHU's Avatar
    Welcome to Android Central! You have a Pixel 6 as well?
    No. I have redmi note 8 pro
    01-07-2022 02:16 AM
  15. B. Diddy's Avatar
    Open your Google app, tap your profile pic at the upper right, then Settings>Voice>Offline Speech Recognition.
    01-07-2022 12:10 PM
  16. scrutineer's Avatar
    Open your Google app, tap your profile pic at the upper right, then Settings>Voice>Offline Speech Recognition.
    Would you happen to know how to access these settings on a Samsung Galaxy S10?
    01-08-2022 02:41 AM
  17. B. Diddy's Avatar
    Welcome to Android Central! It shouldn't matter if you're on a Samsung phone -- these settings should be in the Google app itself. I can confirm this on my Galaxy A32 5G.
    01-08-2022 02:47 AM
  18. chez6229's Avatar
    None of these paths worked on my S20 (on the Sprint network). I had to go to my phone's Settings > Google > Settings for Google Apps > Search, Assistant & Voice > Voice > Offline Speech Recognition. From there, there are three tabs at the top (Installed, ALL and Auto-Update). Choose the Auto-Update tab and change your selection to the choice in the middle that says "Auto Update languages at any time. Data charges may apply."
    bzccat likes this.
    01-10-2022 06:15 PM
  19. mustang7757's Avatar
    None of these paths worked on my S20 (on the Sprint network). I had to go to my phone's Settings > Google > Settings for Google Apps > Search, Assistant & Voice > Voice > Offline Speech Recognition. From there, there are three tabs at the top (Installed, ALL and Auto-Update). Choose the Auto-Update tab and change your selection to the choice in the middle that says "Auto Update languages at any time. Data charges may apply."
    Welcome to AC!
    I took care the other post for you.
    chez6229 likes this.
    01-10-2022 06:26 PM
  20. Cat Nip's Avatar
    I found the solution. There is a separate setting for wifi/cellular download for speech services, from the Google play store wifi/cellular download.

    Search "digital assistant app" in the settings search bar. Both gear icons in this menu, one at the top for which assistant is set for your device, and the bottom gear for speech services, both have options to change download via wifi/cellular.

    "Default digital assistant app" gear icon, then "offline speech recognition" midway down, then "auto-update" tab on far right side.

    "Voice input" "Speech services by Google" gear icon, then "auto update languages."
    For those with xiaomi devices
    Go to app settings, then manage app, then default settings, look for the assist and voice input.
    01-11-2022 04:27 AM
  21. Imran Sagor's Avatar
    For those with xiaomi devices
    Go to app settings, then manage app, then default settings, look for the assist and voice input.
    Not solved yet 😕
    01-11-2022 05:48 PM
  22. bzccat's Avatar
    Ok so none of the above worked for me. S20+ in Australia on Telstra network and on wifi.
    I had to uninstall the current update and then reapply the update in the google play store (search for: speech services by google).
    Then went into the google settings and manually selected download for offline speech recognition voices.
    Settings > Google > Settings for Google Apps > Search, Assistant & Voice > Voice > Offline Speech Recognition > Installed > English (US) > Download
    (thanks chez6229 for that location)
    01-11-2022 07:07 PM
  23. mustang7757's Avatar
    Ok so none of the above worked for me. S20+ in Australia on Telstra network and on wifi.
    I had to uninstall the current update and then reapply the update in the google play store (search for: speech services by google).
    Then went into the google settings and manually selected download for offline speech recognition voices.
    Settings > Google > Settings for Google Apps > Search, Assistant & Voice > Voice > Offline Speech Recognition > Installed > English (US) > Download
    (thanks chez6229 for that location)
    Welcome to AC!
    So all good now ?
    01-11-2022 07:33 PM
  24. mustang7757's Avatar
    Not solved yet
    Welcome to AC!
    You tried all suggestions here ? Which device?
    01-11-2022 07:34 PM
  25. mustang7757's Avatar
    Just so the New members are aware this a pixel 6 forum , so your settings may vary on different devices and region.
    01-11-2022 07:35 PM
  26. msawyer1984's Avatar
    None of these paths worked on my S20 (on the Sprint network). I had to go to my phone's Settings > Google > Settings for Google Apps > Search, Assistant & Voice > Voice > Offline Speech Recognition. From there, there are three tabs at the top (Installed, ALL and Auto-Update). Choose the Auto-Update tab and change your selection to the choice in the middle that says "Auto Update languages at any time. Data charges may apply."
    I tried the same process as shwn for the Galaxy S20 on my S10 and it still says waiting for a network connection with Wi-Fi and without. I restarted my phone and I get it back. How do I kill it even after making these changes?
    01-11-2022 08:01 PM
117 123 ...

Similar Threads

  1. Why my mobil updating after update again
    By Android Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-02-2021, 12:02 AM
  2. nochange service provider software version
    By Android Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-01-2021, 09:42 PM
  3. Update Still October
    By mustang7757 in forum Samsung Galaxy Z Fold 3
    Replies: 7
    Last Post: 11-01-2021, 08:06 PM
  4. Replies: 2
    Last Post: 11-01-2021, 07:51 PM
  5. US unlocked update - still Oct security patch
    By FACTagent in forum Samsung Galaxy Z Fold 3
    Replies: 0
    Last Post: 11-01-2021, 09:41 AM
LINK TO POST COPIED TO CLIPBOARD