1. AC Question's Avatar
    Everytime I try to navigate anywhere I always get the same error message. It tries to start navigation, then says "try again on your phone".

    Has anyone else experienced this?
    07-09-2014 12:02 PM
  2. VW Maverick's Avatar
    What device do you have?
    Using the Google Navigation that came with the device?

    07-09-2014 12:17 PM
  3. davesherman's Avatar
    I'm getting exactly the same on my Samsung Gear Live when it attempts to use Google Maps (is there another Nav option available yet?) - would also love to know the fix if there is one? Thanks!
    07-11-2014 05:45 PM
  4. t3rabyte's Avatar
    Man, this was a frustrating problem. This happened after I got a replacement watch.

    Just open up Settings > Applications on your phone, choose Android Wear, then Clear Cache (not Clear Data).

    Then, restart your watch.

    Worked for me. Finally!
    08-20-2014 03:31 PM

Similar Threads

  1. Tablet Wont Work Unless I Hold Both Sides Together At The Same Time
    By Kady1422 in forum Google Nexus 7 Tablet (2012)
    Replies: 7
    Last Post: 07-10-2014, 11:06 AM
  2. Cel-Fi and unlocked Moto X - does it work?
    By bdlmotox in forum Moto X (2013)
    Replies: 7
    Last Post: 07-10-2014, 01:23 AM
  3. play store not work
    By saman samni in forum Ask a Question
    Replies: 1
    Last Post: 07-09-2014, 12:40 PM
  4. Replies: 0
    Last Post: 07-09-2014, 11:49 AM
  5. Saying "Okay Google" Doesn't work
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 07-09-2014, 11:02 AM