1. AC Question's Avatar
    I have a Trio Stealth G2 Tablet. This tablet has already given me a ton of problems in the past. This latest one is when I try to access the Storage in my settings I get this error.

    I have an SD inside the tablet, it reads when I remove and replace the SD card. However, when the SD is removed from the Tablet I can see the storage. When the SD is placed in the Tablet, I cannot. So this lead me to assume something is wrong with the SD card. This was not the case. Also, this SD card has worked before on this tablet before I did the latest factory reset.

    The SD card still works in my PC, I have reformatted this SD twice already. I have tried another SD card as well and still get the same error. I have factory reset the tablet with the SD removed. The only thing I haven't done was try to boot into safe mode, but I don't thing that would help my issue.

    Any help?
    07-19-2014 03:26 PM
  2. B. Diddy's Avatar
    Unfortunately, off-brand devices like yours have a relatively high rate of hardware or firmware defects. You probably won't find a good solution here, sorry!
    03-04-2015 10:21 PM

Similar Threads

  1. My Moto G Lag has been getting hot and draining fast this week?
    By officially_juju in forum Moto G (2013)
    Replies: 4
    Last Post: 07-24-2014, 06:13 PM
  2. My S4 has slowed to a crawl
    By aflacks in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 07-20-2014, 09:23 AM
  3. Smart Sound settings app for S5?
    By FastMoneyPlaya in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 07-19-2014, 03:08 PM
  4. Navigation app with multiple stops.
    By lornaevo in forum Google Nexus 5
    Replies: 3
    Last Post: 07-19-2014, 01:28 PM
  5. Email -Stock widget settings?
    By LauraWA in forum LG G3
    Replies: 0
    Last Post: 07-18-2014, 05:20 PM