1. PsychoBillyCadillac's Avatar
    I have a Verizon Galaxy S3 with version 4.4.2. I use an app called Waze and the GPS is not working. I made sure GPS is on. In a forum I tried a fix which actually fixed the GPS problem on Google maps for navigation by going into App manager, all, maps, then push "clear data" and "uninstall updates". Then I restarted phone and tested the device and Google maps works now.

    So I tried the same process for the Waze app and it did not work.

    Does anyone know how to fix this GPS problem on Waze?

    Posted via the Android Central App
    12-02-2014 07:59 PM
  2. Lschinaia's Avatar
    It should work in the Waze app, GMaps quits on my all the time while I'm driving and never alerts. I drive down the road and realize it's frozen. Hate GMaps now.

    Try reinstalling the Waze app, and then writing them on the "ask question" part of the app. Might be a software issue, or your gps is malfunctioning.
    12-02-2014 08:15 PM

Similar Threads

  1. Replies: 5
    Last Post: 02-11-2015, 09:58 PM
  2. Replies: 9
    Last Post: 12-17-2014, 06:33 PM
  3. Replies: 2
    Last Post: 12-03-2014, 08:34 AM
  4. Why is my S5 changing settings back to default on its own?
    By Zonayork in forum Samsung Galaxy S5
    Replies: 0
    Last Post: 12-02-2014, 07:39 PM
  5. Replies: 0
    Last Post: 12-02-2014, 07:18 PM