1. AC Question's Avatar
    I am on a Nexus 5x running 7.1.1. Earlier today found no cards on the Google Now screen, just this message: "New Version Available A more recent version of the Google app is available for download". So tapped the link which took me to the Play Store and the Google App. Where there is no update available, just options to open or uninstall.

    Hitting open loops me right back to the above message.

    Fixes I have tried: Turning Now off and back on. Deleting card preferences. Uninstalling Google and the Now Launcher and reinstalling both. Turning location services off. Have also checked that Settings>account & privacy>Google activity controls>web & App activity is set to "On". Oh, and switching my phone off and on again :-) None worked. Any help would be greatly appreciated.
    01-28-2017 01:14 PM
  2. MarkPit's Avatar
    I'm having the same problem and I've seen reviews of the app in the play store stating the same. I have a feeling this is fairly widespread.
    01-28-2017 03:01 PM
  3. 0ysterman's Avatar
    Yea i have the same problem. Did all the steps you did and i come to the same problem
    01-28-2017 03:43 PM
  4. Amamiya Hotaru's Avatar
    If there is an error code, please contact Google play store to solve the problem. Or check the network
    02-04-2017 03:22 AM

Similar Threads

  1. Samsung galaxy e7 touchscreen not working
    By AC Question in forum Ask a Question
    Replies: 3
    Last Post: 10-25-2017, 01:49 PM
  2. Replies: 2
    Last Post: 01-28-2017, 04:39 PM
  3. Cant find google play store on application manager
    By doraemonLove in forum Google Play Store
    Replies: 1
    Last Post: 01-28-2017, 11:05 AM
  4. Why my Xperia z3 workes only One earphone
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 01-28-2017, 10:57 AM
  5. WiFi/Data Connection Stops Working
    By NexusGirlX in forum Samsung Galaxy Note 4
    Replies: 0
    Last Post: 01-28-2017, 08:13 AM