1. AC Question's Avatar
    I'm looking for a simple solution like this one (only seems to work on iPhone)
    "Actually this is possible!...

    Use the following instructions:
    1. Tap the blue arrow next to the name of the AirPort Express WiFi network to view more options.
    2. Select "Static" as the type of IP address, and then enter the following IP address and Subnet Mask :

    IP Address : 10.0.1.4 (for example)
    Subnet Mask: 255.255.0.0

    Make sure you leave Router, DNS, and Search Domains blank! This tells the iPhone that it should use its cellular network to route internet traffic rather than trying to do it via WiFi."

    What I'm trying to do is connect to Chromecast but use my 4g to stream Netflix. I can't get internet in my home (Comcast, dial up, whatever). My phone plan has unlimited 4G which is why I thought that Chromecast is a good option. I can't use a MHL connection (phone to HDMI) because my S7 edge doesn't support MHL.

    I've tried using a firewall app which hasn't worked. As soon as WiFi is connected my 4G signal gets terminated on my phone.

    Thanks in advance to any suggestions.
    04-26-2017 10:43 PM
  2. jcummins42's Avatar
    This question asked back in April....ive got the same issue.

    No home internet, but do have network. Want to log in to wifi for not only above purpose, but printing and viewing security cameras....without losing my 4G connection.

    Can it be done?
    06-16-2017 06:04 PM
  3. hallux's Avatar
    Enable Developer options https://www.androidcentral.com/all-a...eloper-options

    One of the options in there is to keep cellular data active when WiFi is connected (on my Nexus 6p anyway)...
    06-16-2017 07:33 PM
  4. jcummins42's Avatar
    Enable Developer options https://www.androidcentral.com/all-a...eloper-options

    One of the options in there is to keep cellular data active when WiFi is connected (on my Nexus 6p anyway)...
    Thanks....i'll definitely give that a try.
    06-16-2017 08:46 PM
  5. jcummins42's Avatar
    Well found the option 'Keep mobile data turned on'..didn't work. Did restart on phone no change. The option reads..Keep mobile data turned on AT all times, even while Wi-Fi is in use....but it flat doesn't work???
    06-16-2017 09:05 PM
  6. ManiacJoe's Avatar
    It sounds like the problem is that your wifi does not have internet access, which android seems to assume that it does have. Most apps are going to use the wifi connection if it is available regardless of whether or not the mobile data is turned on.

    When apps want an internet connection, they can request it in one of three ways:
    - best available (wifi preferred)
    - wifi only
    - mobile data only

    Normally, most apps use the "best available" option. They don't care what the network type is, but wifi is faster and "free".

    Of the apps that care about the network type, it is usually the SMS/MMS messaging that requires the mobile data connection because it is actually talking to the carrier network, not the internet.
    06-16-2017 10:36 PM

Similar Threads

  1. Replies: 1
    Last Post: 04-26-2017, 10:29 PM
  2. How do i get my original infinix note2 keyboard back?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-26-2017, 10:07 PM
  3. Replies: 0
    Last Post: 04-26-2017, 10:04 PM
  4. Replies: 0
    Last Post: 04-26-2017, 10:02 PM
  5. How to back front camera?
    By AC Question in forum Ask a Question
    Replies: 0
    Last Post: 04-26-2017, 09:58 PM
LINK TO POST COPIED TO CLIPBOARD