1. fuamami's Avatar
    My son received a Trio Stealth tablet for Christmas, and out of the box it worked great. However, about a week and a half ago, it dropped the WiFi and I haven't been able to get it to find it again. It will scan and find the neighbor's network, and last night we took it to Best Buy and it connected to their network. But at home, no go.

    If I manually enter it, it says "Not in Range".

    Any guesses? And, just to save time, I've already reset the router and the phone, rebooted both, etc. Disabled and then re-Enabled SSID Broadcast, and also tried Enabling and then re-Disabling MAC filtering, based on stuff I found on other forums. No worky.
    01-13-2014 10:34 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Ok, see if there are any other tips in this guide that you haven't tried yet; http://forums.androidcentral.com/amb...-problems.html
    01-13-2014 10:38 PM
  3. fuamami's Avatar
    Thanks, tried them all. Still nothing.
    01-13-2014 11:39 PM

Similar Threads

  1. Travelling to the US, need suggestions and places to buy phone/tablet
    By soumian in forum General News & Discussion
    Replies: 23
    Last Post: 02-14-2014, 05:48 AM
  2. Replies: 5
    Last Post: 01-15-2014, 08:27 PM
  3. Replies: 3
    Last Post: 01-14-2014, 05:21 AM
  4. System tries to use unconnected WiFi network
    By Oddible in forum Legacy Android & Other OS's
    Replies: 1
    Last Post: 01-13-2014, 10:16 PM
  5. Pin Number put on Android Tablet and number forgotten!
    By Melany Wright in forum General Help and How To
    Replies: 1
    Last Post: 01-13-2014, 08:06 PM
LINK TO POST COPIED TO CLIPBOARD