1. monsow's Avatar
    Hey guys...

    Since yesterday I've had a problem with my locations on my Nexus 5..

    When I checked the weather yesterday, google now (when I swipe to left from home screen) showed me I was in Italy (and I live in Denmark). I tried restarting, turning off/on locations, turned my location settings to high accuracy (I use battery save as default), logged out/on my google account, and basically everything, and nothing worked. Then I thought I better wait and see what happens, maybe it will fix itself... but now, one day later, google simply cannot determine my location. When I use voice command "where am I" it just searches on google, and when I use google maps to show my location it just says "waiting for location..." and nothing happens.

    I don't know what to do, and this is really a big problem for me because I use location a lot!

    Would appriciate any help, thanks in advance!
    02-12-2014 03:28 AM
  2. mrsmumbles's Avatar
    I don't know if it will do the trick but you could try resetting app preferences. Settings, Apps, All, Reset. Also Date & Time.

    Sent from my Nexus 5 using Tapatalk 2
    monsow likes this.
    02-12-2014 04:09 AM
  3. monsow's Avatar
    Just tried, didn't work
    02-12-2014 04:34 AM
  4. mrsmumbles's Avatar
    In Settings,Location is everything on? If so I'm not sure what else to suggest. Sorry. :-/

    Sent from my Nexus 5 using Tapatalk 2
    monsow likes this.
    02-12-2014 05:12 AM
  5. monsow's Avatar
    Hey! Actually, after I did what you suggested the first time, it worked as normal after 5-10 minutes !! thanks a lot
    mrsmumbles likes this.
    02-12-2014 05:22 AM
  6. mrsmumbles's Avatar
    Cool, great to hear.

    Sent from my Nexus 5 using Tapatalk 2
    monsow likes this.
    02-12-2014 06:15 AM
  7. Alexandre De Oliveira's Avatar
    i'm experiencing the exact same symptoms, except the discussed solution didn't help me, maps is not able to fix a location with gps turned on either.

    i uninstalled updates, and reupdated maps to latest version but without success

    cleared cache and dalvik cache, no improvement...
    02-12-2014 09:42 AM
  8. camanokid's Avatar
    Did you power OFF/ON?
    02-12-2014 10:17 AM

Similar Threads

  1. Replies: 5
    Last Post: 05-08-2014, 12:07 PM
  2. Nexus 4 battery problem
    By usmanyousaf in forum Google Nexus 4
    Replies: 4
    Last Post: 02-12-2014, 08:56 AM
  3. What is a better mkv player with accurate subtitles?
    By neivian in forum General News & Discussion
    Replies: 0
    Last Post: 02-12-2014, 01:42 AM
  4. Problem with S note, can't input numbers
    By Oh_no_bro in forum AT&T Samsung Galaxy Note 3
    Replies: 0
    Last Post: 02-12-2014, 01:00 AM
  5. Replies: 1
    Last Post: 02-12-2014, 12:09 AM