09-25-2016 01:06 PM
115 ... 345
  1. BigPaul V's Avatar
    It was the battery connection. Thank you so much
    Snegley1 likes this.
    11-11-2013 09:41 PM
  2. Hayden Heun1's Avatar
    you have a point
    01-12-2014 07:11 PM
  3. Griff88's Avatar
    My Nexus 7 wouldn't turn on tonight. Nothing I tried would get it to work. Tried different chargers, different cables and all the usual reset tricks. Still nothing.

    If anyone else has the same symptoms I implore you not to panic and simply remove the back and check the battery connector. Even the slightest movement of it, less than 1mm, renders the device useless. Simply lift out the battery carefully and replace it (to allow the battery wires more slack) and plug in the connector again. It should then imediately turn on again or show the charging symbol.

    It's that simple!
    01-13-2014 05:33 PM
  4. Franklin Herman's Avatar
    I've had the same issue on and off for several months. I've owned the device for about 18 months now and love it when its working. As for my wifes iPad, she has had it for over two years and the thing is solid as a rock (she uses it all the time).
    05-16-2014 09:35 AM
  5. Kristen Parke Beech's Avatar
    Thankyou so much for your feedback.. I am going overseas today and OMG I was shattered...but I did hold down for 30 seconds and bing its on...I cant thankyou enough.. will do something about issue though cause quite stressful especially this morning...didn't need it..
    Omg Im so happy, you have no idea.. well you probably do.. Thanks again Krissy
    06-17-2014 04:11 PM
  6. Josh Meade1's Avatar
    That is a manufacturer error so call google to get it replaced

    Posted via Android Central App
    06-17-2014 04:50 PM
  7. nhkat's Avatar
    If it won't turn on it won't go into bootloader mode anyway. Mine is just plain dead, only worked about ten times total and it's junk. I bought it so that I could follow my football pool at work before I had a smart phone. I used it about six times and had to send it back to Asus because it wouldn't turn on they supposedly fixed it but, it worked another four times and now it's dead again. I paid 200 dollars for this piece of crap and I sure don't have to think about if I am going to buy another one. I will not throw good money after bad. With all the complaints I have found about it online I am surprised there isn't a class action suit against them anyway. What a piece of ****. I have tried re seating the battery I have tried to get it into bootloader mode tried charging it for days on end and nothing.
    11-24-2014 07:20 PM
  8. c172av8tr's Avatar
    A similar situation encountered with a friend's Nextbook. The on/off switch or connection was faulty. I replaced the switch and it works fine now. This may or may not be the same situation you are encountering. To correct the situation, requires some electronics knowledge,a digital multimeter, set of small flat-head and Phillips screwdrivers, soldering "know-how" and most importantly, plenty of patience. Also getting the case opened as well as resealing requires following different sequence of events to ensure proper seating and not damaging the case. It took me a couple of times to reopen and reseat the case because one exterior button was not actually touching the button on the circuit board.

    Perhaps an electronics repair place may be able to help if your device is out of warranty or you don't want to get involved with a tedious repair task. Otherwise, you may be able to search for repair parts and perhaps the electronics repair could install them (most likely with no guarantees).

    I hope this helps.
    01-15-2015 09:07 PM
  9. Anita Banta's Avatar
    I tried to open my tablet, but couldn't. Not very good at this kind of thing and I don't have one of those tools that several people talked about. I think I need to get one. I kept holding down the power button for way more than 30 seconds and that didn't work, not even when I had plugged into the charger. Here's what finally worked for me: I plugged in the tablet, and held down BOTH the power and the volume up button at the same time for a while. A little green robotic looking figure showed up that said something like "no command given". I thought I had totally ruined my chances of it powering up, so I just left it alone, and about 5 (10?) minutes later, a sound comes out of it, I check it.......and it's on! Hope this helps someone.
    06-19-2015 11:41 AM
  10. Snegley1's Avatar
    It was my battery connection too...was about to throw it out but thought I'd take one last shot. Cant believe it worked.
    07-10-2015 05:33 PM
  11. magicme's Avatar
    Hi, I've had the same issue, and my Nexus 7 has been dead for about 8 months. Recently I was out of town for a week but forgot to pack my (android) phone charger so bought a new cable as I was able to borrow a charger. Today was the day i was going to try all your tips and tricks, but nothing worked. My battery was snug in its socket, but I did notice that the usb and micro usb were sitting loosely in the charger and Nexus sockets. I had previously tried other cables and charves
    09-07-2015 10:37 PM
  12. magicme's Avatar
    Oops...cables and chargers but they didn't work. As a completely last resort I tried the new cable I'd bought for my phone. Went through the "press and hold the power button and volume down button" etc and it worked!!! This cable sits tightly in both sockets so for anyone who's tried everything but maybe has an old, loose cable, it might be worth spending a few $ on a new cable. Might work for you.
    09-07-2015 10:45 PM
  13. Jayoh717's Avatar
    press and hold both the power and volume+ buttons for about 15-20 seconds, that should do the trick
    Only thing that worked for me. Thanks!!
    01-08-2016 04:10 PM
  14. mj p's Avatar
    My two kids have 2012 Nexus 7s and three days ago BOTH tablets went dead. I tried holding the power button for 30+ seconds; holding power button with volume down button for 30+ seconds; did all that with charger plugged in; repeated it with no charger; removed back cover using pocket knife at top right corner, unplugged battery and replugged it; NADA. Anyway, just tried plugging in Nexus using the new charger from my mobile phone, held down power button with volume down button, and HOORAY, battery charging symbol has appeared on screen. The USB port on the charger supplied with the Nexus seems strangely loose compared to the charger for my Moto... maybe that combined with my kids running the batteries down to 0% created the seemingly unfixable problem?
    09-25-2016 08:02 AM
  15. wess580's Avatar
    Don't worry I had the same problem for some reason if you let the tablet die it does that the fix I used was to leave the tablet on the wall charger for about 15 min the take the cord out then put back in it should start charging right after that let me know if that helped
    09-25-2016 01:06 PM
115 ... 345

Similar Threads

  1. Hmmm my nexus won't turn on anymore
    By Xterror in forum Google Nexus 7 Tablet (2012)
    Replies: 122
    Last Post: 12-19-2014, 06:40 PM
  2. Galaxy Nexus Won't Turn On after Jelly Bean
    By bluedunn in forum Verizon Galaxy Nexus
    Replies: 18
    Last Post: 01-20-2013, 04:22 PM
  3. Stock phone died for no reason, won't turn on
    By Joe92GT in forum Verizon Galaxy S III
    Replies: 1
    Last Post: 07-21-2012, 08:35 PM
  4. Bootloader Unlocked, Phone Won't Turn On, What are my options?
    By legendarydog in forum Verizon Galaxy Nexus
    Replies: 6
    Last Post: 07-01-2012, 12:31 PM
  5. Who else is getting this phone on release day no matter what?
    By barnebyjones in forum Verizon HTC Thunderbolt
    Replies: 44
    Last Post: 03-11-2011, 06:26 PM