1. GTAFan9999's Avatar
    I'm not sure why it's not even at 1%. My phone's battery has exhausted and I plugged in my charger into the USB port of my computer thinking it would charge again. I saw the charging light blink and thought "give it a few minutes". But now after nearly three hours, my phone still refuses to turn on. I've tried:
    1. Using different chargers
    2. Using different outlets
    3. (As before) waited for hours to see any change.
    Now something I'm noticing right now is that when I plug it into my computer it plays the USB in sound. After a few seconds, it plays the USB out sound. It's been doing this for a while. Any ideas on what to do to get my phone up again? I don't have any spare batteries.
    05-05-2012 07:42 PM
  2. piizzadude's Avatar
    pull the battery, pull the sim if you have one. Let it sit for 20 minutes. put everything back in. hopefully profit
    05-05-2012 08:37 PM
  3. GTAFan9999's Avatar
    After 4 hours of unknown activity, my phone just mysteriously turned on by itself. I saw my battery at around 30 or so. Problem solved.
    05-06-2012 11:19 PM
LINK TO POST COPIED TO CLIPBOARD