1. bbarend's Avatar
    My wife broke her Galaxy SII. While we are waiting on parts, we were going to reactivate her EVO 4G. I had been playing with the phone. Flashing ICS and the like. We took it into Sprint to be reactivated. I had since flashed back to Stock Rooted. They cannot activate it. They tried for hours and it wouldn't take the code they had to put into it. They of course say it's because it's rooted. Of course they would have been clueless without me telling them.

    Anybody have any ideas how root would cause this problem? It isn't a concern really. The wife just has to use a dumb phone for a week. I'm just more curious than anything.
    01-12-2012 02:37 PM
  2. airchecknews's Avatar
    I believe the phone needs a Sense ROM on it for activation. I gave my old Evo 4G, running CM7, to my daughter to use and she ran into the same problem. I loaded a rooted stock ROM on the phone and it activated just fine. Not sure the reason, but I found that info elsewhere and it worked. I just downloaded the rooted stock ROM through ROM Manager and it worked like a champ. I don't think it's a problem with root per-se, just with the ROM itself. Her phone activated fine, even with root, once it was loaded with the Sense ROM.
    01-12-2012 02:46 PM
  3. CaMelGuY1337's Avatar
    Man, I thought I had bricked mine sometime back and found out the battery had just died. Anyway, I activated an old flip phone I had laying around until I could figure out what happened. After it charged back up I called Sprint and had them reactivate my rooted EVO. I put everything back as stock as possible without loosing root. They had no issues reactivating it. Make sure your using an actual stock ROM that the Sprint servers can see. Also make sure your WiMAX RSA Keys are still present by using the app I've linked below. When we went to activate over the phone I had to punch in some code on the dialer that rep was telling to me. Everything went just fine, sounds like got hold of a newb rep.


    Sent from the greatest HTC EVO 4G ever made!!!
    01-12-2012 02:48 PM
  4. dizzle16's Avatar
    Yeah before the LG optimus s got gingerbread update I was running cm7 and could not activate. Im sure its because I was running 2.3 on a 2.2 phone. I flashed a 2.2 rom and activated with NO issue
    01-12-2012 02:51 PM
  5. bbarend's Avatar
    I flashed back to the stock rooted ROM and it was still a no go. It was full blown Sense with Sprint bloat on it. They wouldn't have know it was rooted unless I told them.
    01-13-2012 11:41 AM
  6. vulcan001's Avatar
    Thats the problem all users will run into when activating it or changing numbers. Happened to me. I changed my number twice, so i had to switch out to a sense based rom to update the some of the settings.
    01-13-2012 12:08 PM
  7. carhauler1969's Avatar
    If the ROM you're running has the EPST programming menu disabled or removed for whatever reason you cannot activate the phone. Being rooted has absolutely nothing to do with it. Also, if the MSID gets corrupted somehow you won't be able to activate it. A friend of mine had the latter happen when switching service from his rooted EVO to his also rooted EVO 3D, MSID got corrupted & after a couple of hours arguing with Sprint they issued him a new MSID & he was able to activate the phone.

    Sent from my SPH-D710 using Tapatalk
    02-09-2012 01:50 PM
  8. cajunlibra's Avatar
    So, to be clear. If I get a brand new phone and root it first(Stock), we will have no issues activating it?

    I ask because my partner just got a brand new Galaxy S3 and I want to root it for him, preferably before I see him in a week. I know I'm talking about a different phone but I figure the root/activate concern would be universal.

    11-27-2012 11:59 AM
  9. benny3's Avatar
    I agree with carhauler, it sounds to me the epst.apk is the issue
    11-28-2012 06:59 PM