1. bjordan's Avatar
    Has anyone else had an issue not being able to send a text using the stock SMS app in 2.2?

    It doesn't happen to often but when it does it's annoying. I finish typing my message, try to click the "Send" icon button but it doesn't send. It just moves the cursor in the text near the button. It's like the button is not there.

    I can save the message as a draft, go back and send it with no problem but it's annoying.

    Just for the record, I'm not using any task killer's or doing anything unusual on my phone.
    09-02-2010 03:03 PM
  2. gotthelife4u's Avatar
    I have had that happen to me twice since I got the phone. Very inconvenient
    09-02-2010 03:11 PM
  3. parout66's Avatar
    Where is there a setting to change the default sms app? I would like to have handcent handle my sms
    09-02-2010 03:25 PM
  4. ryandroid's Avatar
    Seems to be happening to me more frequently. Wondered if it was the smart keyboard I am using. Pain...
    09-04-2010 07:57 PM
  5. Gmaxxx's Avatar
    I've been having an issue with the SMS' as well. My problem consists of sending a text message to someone and for some reason it will show it sent to another person but the person I intended to send it to will get it. One night i sent a text to a friend and another friend who i had texted earlier had gotten it asking what the hell I was talking about. They better get a fix out for that cause thats kind of ridiculous. I also get the sending problem every once in a while. I will start typing and the send button will not appear to be useable.
    09-04-2010 11:22 PM
  6. taniabonita52's Avatar
    This happened to me once, and then a few minutes later the Touch Input keyboard (on landscape mode) force closed. Yet the keyboard worked fine in portrait mode. Mind boggling. I shut off the phone and turned it back on, but I found that so odd. I was more astounded that annoyed. I hasn't happened anymore, and I hope it doesn't happen again.
    09-05-2010 02:04 AM
  7. jlewis's Avatar
    Any solution to this issue, yet?

    I have the same issue. The workaround I found is to hit the back arrow to exit out of the text, and the EVO will automatically save the text as a draft. Then you have to hit the MENU button to call up any draft messages, and then you can hit the SEND from there. It's a pain, but it works if you have a long text already typed.
    09-16-2010 09:15 AM
  8. CricTic's Avatar
    Have you tried dismissing the keyboard before sending the SMS, by hitting the keyboard-down button on the left?

    The only other suggestion I would have would be to install a different keyboard. I've been pretty happy with the stock Android one ... I was always hitting the directional buttons instead of space with the HTC keyboard, and the stock Android one doesn't have those buttons so my typing speed has improved.

    Stock Froyo keyboard available for HTC EVO 4G

    Would have loved to try Swype but I missed that beta train :-/
    09-16-2010 01:00 PM
  9. JoshBrunz's Avatar
    Solved by changing the keyboard height. Make it a little bigger or smaller. Works again.
    07-29-2016 10:17 PM