1. Michael Tomsic's Avatar
    I've been searching around for a couple days now and nothing I've found seems to help so far.

    Starting about a day or two after I got the Android 5.0 update (day before Thanksgiving), my Nexus 4 seems to run into a LOT of issues now with multiple apps.

    1. Messaging [Google app] essentially stopped working - I could no longer receive any SMS or MMS messages. When I tried to send, they would be stuck as "Sending" for a while (hours) and apparently when they were finally sent through, they got sent multiple times over the course of several hours.
    2. GMail would no longer open - clicking on the icon would turn the screen white for a second or two, then it would go back to the Android home screen.
    3. Google+ would no longer open - same situation as GMail, although now it seems to open, but the latest post I see is from 7 days ago. Trying to refresh gives me a notification (toast) stating: "Can't load data. Check your connection. Tap to retry." Which is odd, because my connection seems to be fine since I can still use Chrome with no problems.
    4. Keep - Opens but doesn't see any latest changes
    5. Play Store - Opens, but the screen says "Authentication is required. You need to sign into your Google Account." and shows a "Retry" button.

    Basically, it seems like most of my Google apps don't function at all, but other apps appear unaffected. (Chrome, Candy Crush Saga, Phone which can both send and receive calls without any problems, etc...)

    So I did some digging.

    The Play Store issue made it sound like there was some kind of authentication issue between my phone and my Google Account. Various places I've found online have mentioned that I should try removing my Google Account [Settings > Accounts > Google] on my phone and re-add it. But when I try this, it either appears to do nothing, or it displays a message stating: "Remove Account? This change isn't allowed by your administrator". Which again seems odd, since I am the only one who has ever logged onto this device, so why am I not already the Administrator??

    Delving into that, I went to Settings > Security > Device Administrators and tried to deactivate the "Android Device Manager"... which seems to work, and yet the checkbox that indicates its enabled/disabled state never gets unchecked.

    So I went back to the Accounts...

    When I tried to manually kick off a Sync, it seems to get stuck on the very first item in the Sync list, which is "App Data". (icon just keeps spinning and spinning.) When I uncheck the box for "App Data" it resumes with the next item and some of the other items seem to sync up just fine, but others do not. (ie. Chrome works fine, but Gmail gets stuck.)

    So now I'm back to thinking there's still some type of authentication issue going on here between my device and Google.

    The only solution I haven't tried yet is to just do a factory reset, which in my eyes is just giving up on finding the true problem and this could all happen again in the future. I don't exactly want to keep resetting my phone every time something acts up. Right?

    Does anyone have any constructive thoughts or suggestions on how I can get my phone working again?

    More info on my device:
    • Just your basic Nexus 4 device.
    • Never rooted, although I did have Developer Mode turned on a while ago for some tinkering around with writing Android apps, but never got anything complex written or installed via USB.
    • I almost only install Google apps, with an occasional game or two, so I doubt it has anything to do with deliberately malicious apps being installed.
    • I did get a Moto 360 a few weeks ago, but I'm doubtful that that has anything to do with this problem since everything work working fine until after the Android 5 install.

    And help would be greatly appreciated! :-D
    12-02-2014 02:10 PM
  2. anon(5600632)'s Avatar
    It's not unusual to require a factory reset after a major OS update. If it works, which it usually does, it is unlikely to be needed again.

    One less disruptive option worth trying is to reboot into recovery mode then do a cache partition clear. Its a peculiar sequence of pushing power & volume buttons that I can never remember, so you need to google it to get it right. But that may help. Unlike a factory reset, your data and settings will be preserved.
    12-02-2014 07:53 PM
  3. Michael Tomsic's Avatar
    Thanks for the reply.
    I posted on a few forums and while a few had some new suggestions of resolving the issue, none actually worked.
    I ended up just having to do a factory reset.
    I'm glad most of my apps were all backed-up online so I basically lost nothing. (Well, except for 1000+ levels of Candy Crush! But whatevs; I needed an excuse to uninstall that time-waster anyways. haha)
    12-08-2014 09:49 AM

Similar Threads

  1. Nexus 6
    By down1plus2 in forum General Carrier Discussion
    Replies: 3
    Last Post: 12-08-2014, 08:52 PM
  2. Replies: 4
    Last Post: 12-05-2014, 01:57 AM
  3. Replies: 2
    Last Post: 12-03-2014, 10:25 AM
  4. Why am I getting the error message UI has stopped while the USB is connected?
    By Abrahman McGuyenski in forum Legacy Android & Other OS's
    Replies: 2
    Last Post: 12-02-2014, 02:17 PM
  5. Replies: 0
    Last Post: 12-02-2014, 12:55 PM