1. krzzz's Avatar
    I just got my S6 and for whatever reason a ton of the apps only work on WiFi when I'm in airplane mode (google playstore, fb sometimes, googlenow), on 4G it works fine. My WiFi connection is fine as my computer's internet is fine and I the speedtest on the S6 yields (20up/5down) when on Wifi.

    As another data point I asked a simple question to google now on my S4 and my S6 while on WiFi at the same time and the S4 answered while the S6 said it couldn't connect to google at the moment. So far the only kinda of fix I have is to stay in airplane mode.

    Has anybody run into similar issues? I've tried the typical fixes ie. restart, forget and reconnect, change to a static ip etc so far no luck.

    I'm going to have to get an iPhone at this rate.

    04-11-2015 12:48 AM
  2. N4Newbie's Avatar
    Two questions:

    1. Who is your cellular carrier?
    2. What are your APN settings? (Settings -> Wireless & networks -> More -> Cellular networks -> Access Point Names)

    And, one more that I am curious about:

    3. Preferred network type? (Settings -> Wireless & networks -> More -> Cellular networks -> Preferred network type)
    04-11-2015 12:56 PM
  3. N4Newbie's Avatar
    One more thought:

    Go to Settings -> Wireless & networks -> Data usage. Tap the three-dot menu icon at top right of screen and select Network restrictions. Is your default WiFi network operating in restricted mode?
    04-11-2015 01:01 PM
  4. sg777's Avatar
    Did you find a fix for this problem?

    On my S6, on T-mobile, I was having a problem where Google Drive (and other apps that access Drive) didn't work on WiFi but did on 4G. (But a web browser on the phone using drive.google.com worked.)

    I found that changing "Network mode" (under Settings -> Mobile networks) to WCDMA/GSM instead of LTE/WCDMA/GSM (i.e., disable LTE) avoided the problem. But disabling LTE isn't a good long term fix.
    Then I found that disabling VoLTE (Phone -> MORE -> Settings -> Voice over LTE settings) avoided the problem, so I'm using that as a long term fix.
    09-23-2015 05:27 AM
  5. skwad's Avatar
    I am having this same issue with my Verizon Moto X once I upgraded to Lollipop. Worked flawlessly under Kit-Kat. Same issue at home and at work, so I don't think it's a router setting. Any suggestions? I've cleared cache and have performed a factory reset.
    10-02-2015 05:16 PM
  6. Blu_Jinn's Avatar
    Okay, figured I'd share my experience with the galaxy s7. First is not my phone, belongs to my girl, that said u had no clue what the base settings were, what all these apps age had came from etc..
    Long long story short.. To ADD to the wifi only works when in airplane mode. Factory resets and router resets were performed. I made sure the s7 was the first and only device connected to the router.. After connecting to the wifi, I accessed the router via Web address, checked settings everything seemed okay.. But u was still having issues...
    It wasn't until u went into my girls Google settings via play store(which now wouldn't event connect) from there I went through all her settings changing and referring back any I thought might effect a connection. As I did though the Play Store loaded up and EVERYTHING worked perfectly fine.
    As a side note e LTE symbol was usually present next to wifi while I was having issues.. So I see how we would think it was a culprit.. But go through your Google play store settings... Our issue was resolved after visiting there.
    03-24-2016 07:27 PM

Similar Threads

  1. How can I make a contact a favorite on the Note 4?
    By AC Question in forum Samsung Galaxy Note 4
    Replies: 2
    Last Post: 08-28-2016, 08:43 AM
  2. Replies: 1
    Last Post: 04-20-2015, 11:26 AM
  3. Missing A-Z organize in app drawer
    By k3rrmit in forum Samsung Galaxy S6
    Replies: 11
    Last Post: 04-11-2015, 07:31 PM
  4. Google trusted sign in
    By TimmE in forum Samsung Galaxy S6
    Replies: 0
    Last Post: 04-11-2015, 12:36 AM
  5. Replies: 0
    Last Post: 04-11-2015, 12:23 AM