1. to.505's Avatar
    Hi,
    I'm new to this forum; I did a quick search and wasn't able to find anything similar to what I'm experiencing with my Samsung Galaxy S3.
    First off, I live in Canada and I'm on the Rogers network (i'm suspecting this might be my answer). I got my phone last Thursday from BestBuy, and this is actually my first smartphone. I started downloading apps and played around with it, but for some reason it just didn't seem that smooth (i read up on a lot of S3 reviews so maybe I have a high expectancy out of this phone?) This might be normal but I am just a bit paranoid because I'm quite unlucky when it comes to getting duds when I buy new stuff. I recently downloaded Quadrant and tested it out, I ran it 4 times (on the 3rd time I restarted my phone), and all 4 times my score came up to 3100-3400 only! I checked everywhere online and people are getting 5000+ average. Is this because of the network I'm in? Or is there something wrong with my phone?
    Please help

    Thanks for taking your time reading this!
    07-09-2012 02:07 AM
  2. DavidsTech's Avatar
    Too many people put stock in a quadrant benchmark. That number would not make me happy or make me question if my phone is fine. Not everyone gets 5,000+. I rarely get over it. Sometimes it's 4800-4900. Even if it was lower I'm not going to want to exchange my device because people are saying they get higher.
    07-09-2012 02:11 AM
  3. mfriedman79's Avatar
    Do you have powersave features turned on?
    07-09-2012 02:29 AM
  4. tohio's Avatar
    Just ran it and got 5015. I have Setcpu and the min and max setting for my cpu is set at 1512 MHz. I shut down any apps running in the background before I ran Quadrant.
    07-09-2012 03:14 AM
  5. to.505's Avatar
    Yes my power saving feature is off. I closed all running applications including clearing ram and I tried running again: 3900. Does this sound normal?

    Thanks for the quick replies everyone, really appreciate it.
    07-09-2012 03:57 AM
LINK TO POST COPIED TO CLIPBOARD