1. Limo_90's Avatar
    Dear All

    I have S4 with no roots or hacks version 4.2.2 .. Yesterday I had a notification that I needed to update S Health to a newer version (1.5.4.5) so I started downloading it then it paused before ending the installation and freezed so I cancelled the download and then re-downloaded it again. It was downloaded and updated successfully, however when I tried to run it, an error message appeared saying that there was an error in running S Health and it needs to close to clicked OK and then the S Health icon and widget disappeared and couldn't find it.
    I tried rebooting the device but no use. I tried finding it on play store and Samsung apps but it wasn't found.
    I also cleared data and cache but no use as well.
    So please help me restore the application on the device because its getting really annoying.
    Thank you
    07-20-2013 05:06 AM
  2. jcastilloalonso's Avatar
    Try going to the application manager and see if it's there, then try to roll back any updates and try to update again.
    07-21-2013 03:16 AM
  3. Limo_90's Avatar
    I checked and its there but I can't check for its updates so is there any other way to solve this problem?
    07-21-2013 03:27 AM

Similar Threads

  1. CWM backup problems
    By nstirton in forum HTC One Rooting, ROMs & Hacks
    Replies: 17
    Last Post: 01-18-2015, 10:08 PM
  2. Android 4.2.2 Update
    By 0313hamiksu in forum HTC One M7
    Replies: 21
    Last Post: 07-22-2013, 05:49 AM
  3. Software update directly
    By s4user1 in forum Samsung Galaxy S4
    Replies: 9
    Last Post: 07-22-2013, 03:01 AM
  4. Lock screen problems
    By JLeung1 in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 07-20-2013, 12:18 PM
  5. Replies: 2
    Last Post: 07-19-2013, 11:40 PM
LINK TO POST COPIED TO CLIPBOARD