1. Vlosaloty's Avatar
    I just bought a S5 that is Verizon branded but came unlocked and I'm trying to get it to work on straight talk. Can anyone give me the data settings that work? I can receive phone calls and texts but have no mobile data. Also when I turn phone off and back on I get this warning that says Sim card is unknown? what is that about? If you can help I'll appreciate it.

    Posted via the Android Central App
    09-04-2014 02:06 PM
  2. Vlosaloty's Avatar
    Nevermind guys I finally got it to work.

    Posted via the Android Central App
    09-04-2014 02:49 PM
  3. Ka Zoua Thao's Avatar
    Hi, could you please give me the instructions how you fixed it? I am having the same trouble but can't find to fix the problem. Thanks it will mean so much!!
    09-09-2014 03:15 AM
  4. bbmjack's Avatar
    Hi, could you please give me the instructions how you fixed it? I am having the same trouble but can't find to fix the problem. Thanks it will mean so much!!
    You need to reset APN

    Posted via the Android Central App
    09-09-2014 08:52 AM
  5. Vlosaloty's Avatar
    Hello sorry I haven't responded sooner haven't been on but yeah I'll give you them. I have found a couple that has worked. It was working great past week then we got that update yesterday and all sudden it changed on me and now the 4GLTE is somewhat iffy and I lose signal for bout 30 secs after a phone call since the update and then it never comes back to a 4GLTE for a long time after I have it off of wifi

    Posted via the Android Central App
    09-10-2014 02:20 PM
  6. Vlosaloty's Avatar
    ok here is the settings I have used since the last update yesterday. You have to create a new APN settings. Just go to settings, then more networks, then mobile networks, then click Access Point Names, then you click the + sign and add these settings

    Name- Straight Talk
    APN: tfdata
    Proxy: not set
    Port: not set
    Username: not set
    Password: not set
    Server: not set
    MMSC: http://mms-tf.net
    Multimedia Message Proxy: mms3.tracfone.com
    Multimedia Message Port: 80
    MCC: 310
    MNC: 410
    Authentication type: not set
    APN type: not set
    APN Protocol: IPv4
    APN roaming protocol: IPv4
    Bearer: LTE
    Mobile virtual netork operator type: none
    09-10-2014 02:38 PM
  7. Ka Zoua Thao's Avatar
    Thank you so much!! Going to try that now !!
    09-12-2014 03:39 AM
  8. Vlosaloty's Avatar
    No problem let me know if that works. I also got the old one I was using before update 4.4.4 to work also. If you need that let me know also

    Posted via the Android Central App
    09-12-2014 08:22 PM

Similar Threads

  1. Replies: 2
    Last Post: 09-15-2014, 04:05 PM
  2. Replies: 2
    Last Post: 09-04-2014, 05:16 PM
  3. Replies: 1
    Last Post: 09-04-2014, 03:33 PM
  4. Blinking Button on Android Optimus G Pro
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-04-2014, 01:20 PM
  5. Replies: 2
    Last Post: 09-04-2014, 01:18 PM
LINK TO POST COPIED TO CLIPBOARD