08-29-2017 03:57 PM
28 12
tools
  1. AC Question's Avatar
    Hi, I have a s7 edge and I am unable to use the youtube app to watch videos. Though I am able to use the browser to watch videos from the YouTube website but I'd rather use the app to have control over the video quality. I am also unable to download or update apps through the play store. All of this is happening through the wifi. When I use the carriers data I am able to do everything just fine. Only way I've found a way around this is by using a vpn service but the speeds are really slow and i would rather just have my wifi. I have tried clearing the cache and data off the youtube app, Google play services/framework, removing my Google account, changing my time and timezone and none of them have worked. I have a feeling it has to do with my location but I live in North Texas so I am really stuck on what I should do. Any help would be greatly appreciated.
    04-06-2016 02:55 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does this happen on any wi-fi network, or only your own? If it's just your own, try rebooting the router, by unplugging its power for 10 seconds, then plugging back in. If that doesn't work, review this guide: http://forums.androidcentral.com/amb...-problems.html

    It might help to log into the router's settings (see the router manual to learn how) and disable IPv6.
    Laura Knotek and Averix like this.
    04-06-2016 06:00 PM
  3. Bartman962's Avatar
    I also have the same problem. Youtube app and play store doesn't work over wifi anywhere I go. The problem is the new update. 6.0.1 which is screwing up the wifi. I have called Samsung Support and they said that it's not just the s7 or the s7 edge that is having problems with the wifi, all the new android phones that was just released are having that problem. Google just needs to fix the update.
    04-10-2016 02:39 AM
  4. PJRed2008's Avatar
    There was already an update sent out for the wifi fix. I have no problem with either youtube or play store on my phone. Download speed is excellent on my system using either 2.4 or 5G.
    04-10-2016 01:40 PM
  5. ChiTown53's Avatar
    When did u get that wifi fix? Im still having issues as well.
    04-23-2016 04:43 PM
  6. Afsound's Avatar
    I'm having same issues.

    I'll check my router settings, but I shouldnt have to be doing this. Hoping for a fix.
    04-24-2016 10:42 AM
  7. Kevin OQuinn's Avatar
    I also have the same problem. Youtube app and play store doesn't work over wifi anywhere I go. The problem is the new update. 6.0.1 which is screwing up the wifi. I have called Samsung Support and they said that it's not just the s7 or the s7 edge that is having problems with the wifi, all the new android phones that was just released are having that problem. Google just needs to fix the update.
    That doesn't make much sense to me since Google has phones that are on 6.0.1 that don't have this issue.

    Also for the record I'm not having this issue with my S7e. I can't recall EVER having this issue, even before any device updates were sent out.
    04-24-2016 12:58 PM
  8. lterry913's Avatar
    Well there are a lot of us that are having issues and using a guest network at home worked for a while, but as of this week it seems the problem is worsening again. I have to keep turning off wifi and turning it back on to reconnect when I get home. No problem anywhere else.
    04-25-2016 01:11 PM
  9. Averix's Avatar
    I had this problem and it traced back to IPv6 addressing. My cable modem apparently cannot interface properly with the cable internet's IPv6 assignment. What ends up happening is the phone requests an IPv6 address and the router either hands out some bogus crap or nothing based on what it thinks the cable modem is telling it. It messes up the phone's ability to talk to Google or YouTube since they have IPv6 addressing implemented. Shutting off IPv6 address assignment on my router fixed this issue. It may or may not be your problem, but I've seen this on other forums for many users as an issue also.
    Kevin OQuinn likes this.
    04-25-2016 02:45 PM
  10. Bag of Leaves's Avatar
    I had this problem and it traced back to IPv6 addressing. My cable modem apparently cannot interface properly with the cable internet's IPv6 assignment. What ends up happening is the phone requests an IPv6 address and the router either hands out some bogus crap or nothing based on what it thinks the cable modem is telling it. It messes up the phone's ability to talk to Google or YouTube since they have IPv6 addressing implemented. Shutting off IPv6 address assignment on my router fixed this issue. It may or may not be your problem, but I've seen this on other forums for many users as an issue also.
    Have you tried syncing the IPv6 info. from your modem to your wireless router? A couple months ago, a family member's Android phone (not a new one) stopped working with the Wi-Fi and it turned out that the router's IPv6 settings weren't the same as the cable modem's settings. Fixing that fixed the problem.
    04-25-2016 09:35 PM
  11. louzer's Avatar
    I'm going way out on limb and guessing you are all on Comcast Internet. I don't have that problem in my house, but just last night I helped someone else with this.

    You can get to the youtube pages that list the videos, but when you select a video, you get a network error message?

    If this is your problem, go into your WiFi settings for your ssid and change the DNS servers from Comcast 's to 8.8 8.8 and 8.8.4.4 (Google DNS servers).

    I didn't try the Google Play store there, but Comcast (in some areas) is messing with YouTube! Yay net neutrality!!!

    I couldn't find where to set the DNS servers for DHCP (I'd appreciate any tips on this) but you can set the DNS for a static IP.

    Posted via the Android Central App on the edge
    04-25-2016 10:18 PM
  12. Bag of Leaves's Avatar
    I use my own Wi-Fi router, not one from Comcast Xfinity, so I can't tell you where to find the settings (I think they have multiple routers they lease out, anyway). I think mine is a D-Link. I use Comcast's modem, but not sure which one it is, as I know they have a bunch. I have X-1 service.
    04-25-2016 11:51 PM
  13. louzer's Avatar
    I use my own Wi-Fi router, not one from Comcast Xfinity, so I can't tell you where to find the settings (I think they have multiple routers they lease out, anyway). I think mine is a D-Link. I use Comcast's modem, but not sure which one it is, as I know they have a bunch. I have X-1 service.
    I was asking where you can set the DNS servers within the phone's WiFi setting for the SSID you're trying to connect to.

    Posted via the Android Central App on the edge
    04-25-2016 11:56 PM
  14. Bag of Leaves's Avatar
    Ah, sorry! Found it - when setting up the connection (entering the password), tap the checkbox for "Show advanced options", under "IP settings" tap the pull-down (default is "DHCP") and select "Static", then the options will appear. The options are: IP address, Gateway, Network prefix length, DNS 1, and DNS 2. DNS 1 default is 8.8.8.8 and DNS 2 default is 8.8.4.4.
    04-26-2016 12:27 AM
  15. louzer's Avatar
    Ah, sorry! Found it - when setting up the connection (entering the password), tap the checkbox for "Show advanced options", under "IP settings" tap the pull-down (default is "DHCP") and select "Static", then the options will appear. The options are: IP address, Gateway, Network prefix length, DNS 1, and DNS 2. DNS 1 default is 8.8.8.8 and DNS 2 default is 8.8.4.4.
    Right. But if you want to use DHCP and not Static (so you don't inadvertently step on another device's IP address and don't want to reset your DHCP range, how do you set the DNS servers?

    Posted via the Android Central App on the edge
    04-26-2016 10:50 AM
  16. lterry913's Avatar
    Ok...Di both dns1 and 2 get set to 8.8.4.4 our just one of them and which gets what numbers?
    04-26-2016 01:54 PM
  17. lterry913's Avatar
    Ok...do both dns1 and 2 get set to 8.8.4.4 our just one of them and which gets what numbers?
    04-26-2016 01:55 PM
  18. louzer's Avatar
    At my friend's house the DNS servers were set to Comcast's DNS servers which was causing youtube videos not to display. I wanted to change the DNS servers to Google 's but could only access DNS servers if I set up my wife in his home with static IP instead of letting his router deliver a non-conflicting IP address via DHCP.

    Posted via the Android Central App on the edge
    04-26-2016 05:35 PM
  19. Bag of Leaves's Avatar
    Right. But if you want to use DHCP and not Static (so you don't inadvertently step on another device's IP address and don't want to reset your DHCP range, how do you set the DNS servers?

    Posted via the Android Central App on the edge
    It doesn't let you do that, though there might be an app that will. Just pick a high IP address that isn't likely to be picked, or if you can access the router, set a reserved IP for the phone.
    04-27-2016 03:12 PM
  20. Averix's Avatar
    Have you tried syncing the IPv6 info. from your modem to your wireless router? A couple months ago, a family member's Android phone (not a new one) stopped working with the Wi-Fi and it turned out that the router's IPv6 settings weren't the same as the cable modem's settings. Fixing that fixed the problem.
    The actual cable modem has no valid IPv6 address. It's a known issue with several cable companies and cable modem models. Honestly, just turn it off at this point unless you need it for work or something.
    05-03-2016 04:34 PM
  21. lterry913's Avatar
    Do you turn off ipv6 on the phone or where?
    05-04-2016 09:09 AM
  22. Dibusz 82's Avatar
    Thanks for help!!! Its working on my tab and phone !!!!!!

    here is it Wifi not working with youtube app or play store-screenshot_2016-05-14-19-10-20_1-1-.jpg
    lterry913 likes this.
    05-14-2016 12:18 PM
  23. alyssapatriciaangeles's Avatar
    Thanks for help!!! Its working on my tab and phone !!!!!!

    here is it Click image for larger version. 

Name:	Screenshot_2016-05-14-19-10-20_1 (1).jpg 
Views:	4 
Size:	91.1 KB 
ID:	227531
    Hello I have the same problem on my phone 😟😔 I am not so techy and I find the thread very foreign. Please help me.. in simple english
    05-23-2016 11:52 AM
  24. lterry913's Avatar
    Bag of leaves gave the clearest explanation....when setting up the connection (entering the password), tap the checkbox for "Show advanced options", under "IP settings" tap the pull-down (default is "DHCP") and select "Static", then the options will appear. The options are: IP address, Gateway, Network prefix length, DNS 1, and DNS 2. DNS 1 default is 8.8.8.8 and DNS 2 default is 8.8.4.4.
    05-28-2016 08:36 AM
  25. one time's Avatar
    Hi, I had the same problem. Bought S7, Wifi works but cant use play store and Youtube App at work. but worked fine at home.
    I called my serivce provider (rogers) and they fixed it by disabling Voice over LTE . apparently this new technology is interrupting signals.worked for me.
    06-29-2016 01:29 PM
28 12

Similar Threads

  1. S7 edge I am having problems with sd card notification what can I do?
    By AC Question in forum Samsung Galaxy S7 edge
    Replies: 5
    Last Post: 04-14-2016, 06:53 AM
  2. My sgS4mini does not turn on after reset
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 04-06-2016, 04:15 PM
  3. Replies: 1
    Last Post: 04-06-2016, 04:13 PM
  4. Replies: 1
    Last Post: 04-06-2016, 03:03 PM
LINK TO POST COPIED TO CLIPBOARD