1. j0esmoe13's Avatar
    I received my GS2 yesterday and am trying to access my SD card through my computer. When I plugged it in for the first time and he began to install a notice popped up that the "MTP USB Device" failed to install successfully.

    I tried to format the SD card and that did not work. Suggestions?
    10-14-2011 08:33 AM
  2. ttlphotography's Avatar
    try putting the phone in usb debugging mode. then select from the drop down menu(notification bar) to connect via usb. It will take a few seconds to connect and the little green droid robot will pop up and there will be a button at the bottom to push to connect. Once it connects the robot will turn from green to orange.
    you should get 2 drives show up. the sd card and the usb internal storage. On my phone, i had already named my sd card, so that name came up and the internal usb storage on the phone came up as "no name". so if you havent named the sd card, be careful in which drive you select as its possible both will come up with "no name". You may be able to tell the difference by the drive size if your sd card is bigger or smaller than the 16gb of onboard phone storage.

    usb debugging mode is under menu>settings>applications>development.
    Leave the usb cord unplugged from the phone, select debugging mode, then plug the usb cord back in and follow instructions above.

    Once youre done doing what you need to do with the internal storage and the sd card, turn off usb debugging mode.
    10-14-2011 08:37 AM
  3. j0esmoe13's Avatar
    Thanks. Worked perfectly. Hard to believe you have to go through all that to access your SD card.
    10-14-2011 09:15 AM
  4. ttlphotography's Avatar
    no problem. glad it worked out for you.
    the MTP deal will work with KIES(samsungs version of iTunes for lack of a better description) on your computer by just plugging it in via the usb cord. Then you can sync files from your computer to your phone. but thats mostly to your phones internal hard drive if im not mistaken.
    but to access the actual drives, there are a few steps to have to jump thru. but once you do the process a few times it happens pretty quickly.
    10-14-2011 10:05 AM
  5. jSiLeNt619's Avatar
    I'm new to this so my question is. Should you leave your phone in usb debugging mode?
    10-14-2011 03:40 PM
  6. XANAX's Avatar
    I leave debugging on all the time with no ill effects.
    10-14-2011 05:51 PM
  7. falconbrunch's Avatar
    I want to do the same thing: access the SD card in my SGS2 through my computer. I do what has been suggested (put the phone in debugging mode, then connect via usb) but no notification appears in the pull-down menu. Any ideas? I've been looking all over the internet to no avail.

    I have also tried going through wireless and network -> USB utilities -> USB mass storage and tapping "Connect storage to PC." This route forces me to turn debugging off. When I connect to my OS X macbook via USB, no notification appears.

    11-09-2011 04:57 PM
  8. tunie's Avatar
    It sounds like you might not have installed the drivers on your Mac for your phone. Did you install Kies?
    11-09-2011 05:58 PM
  9. falconbrunch's Avatar
    I used Kies for the first time last night. It operated through my Macbook's browser (Rockmelt). I'm not aware that any drivers were installed. I'd prefer not to use Kies in the long run because I intend to sync a large music collection and Kies doesn't seem capable of transferring many files at once. Do I need to install drivers to simply mount the SD card?
    11-09-2011 06:08 PM
  10. tunie's Avatar
    I don't use Kies, but I needed the drivers so my PC would recognize my phone. I just drag and drop files from my PC to my phone and back. Your Mac needs drivers to recognize your phone. You can get the correct drivers from samsung.com - click on support. Just search for your model and hit download and it'll show you the drivers for your Mac. <edit> You shouldn't have to install Kies to connect to your MAC but, given that you're not seeing USB in your notification bar, I thought installing the correct Kies might help. Unfortunately, you'll need Kies at some future point anyway, so might as well get it overwith:-)

    This is how it should work:

    -Enable usb debugging from Menu > Settings > Applications
    -return to home screen
    -plug usb cable in
    -pull down status bar
    -press ‘ connect usb storage’ button (At this point, since you don't see anything in your notification area, if you go into settings>wireless and network> USB Utilities, what happens if you press the button "Connect the storage to PC"
    11-09-2011 06:13 PM
  11. falconbrunch's Avatar
    OK. Thanks for the help. I'm disappointed that Samsung wouldn't include a CD-ROM or at least instructions to download the drivers if they're essential. Is this the correct download?

    Mobile Phone's Software&Manual SAMSUNG
    11-09-2011 06:22 PM
  12. tunie's Avatar
    You know, whether you have a Mac or a PC, the systems should take care of recognizing the external storage on the phone. I have read though, that some folks, for whatever reason, have problems connecting to their computers. I ran into trouble initially, so read and read. I had to install Kies because I wanted to root. The info above should work. You might want to start by shutting down your phone and turning it back on before you try connecting again.
    11-09-2011 06:40 PM
  13. falconbrunch's Avatar
    I got so frustrated with this thing that I stopped trying for a while. I have some free time again, so I have resumed my mission.

    I installed Kies on my mac. Now, when I turn on debugging and connect the USB cord, I get a notification in the Galaxy's status bar. I can click "connect usb storage." ...then what? There is no option to mount. No new drive appears in Finder.

    One funny quirk: when I connect the USB cord, I get a message on the computer that reads "A new network interface has been detected. The "SAMSUNG MODEM" network interface has not been set up. To set up this interface, use Network Preferences." I don't want to use the phone as a modem. I want to sync music files on the SD card within the phone.
    11-23-2011 10:33 PM
  14. Reginaldo Rodrigues's Avatar
    algum ae sabe qual o driver que tenho que baixar pra pelo menos solucionar o problema do driver do LG Optimus L4 ii ?
    Entra em contato comigo pelo skype, regzin-r2..

    03-03-2014 09:38 PM
  15. Dr Triffid's Avatar
    Gostaria de tentar fazer essa pergunta nos fruns da LG. Eles teriam uma idia melhor.
    03-11-2014 12:52 AM
  16. tonyheaney's Avatar
    Hi guys

    I have had this issue too and please excuse me as i am a noob on your great site. did anyone finally find a work around for this???
    I would really appreciate any help and answers you can give me.

    05-04-2014 04:06 PM
  17. Beverly Stockton's Avatar
    After MUCH internet research I solved my problem. Had to turn off my internet security and spyware. Hooked my phone back up to my computer. Voila, the computer recognized my phone and I could access the info no my sd card, move pics, etc.
    Karan Gavade likes this.
    10-27-2014 11:03 PM
  18. Elsond78's Avatar
    After about 20 attempts and reboots, I found your post and it worked perfectly! Thanks!
    07-04-2015 02:56 PM