1. maxud's Avatar
    I apologize if this has been discussed here, but I did not see this come up yet, so I wonder if this is only happening with my phone.

    I have ATT Samsung Galaxy S2 and upgraded it to ICS via Kies. The phone is not rooted and 100% stock.
    I was generally pleased with ICS, except for one big problem.
    When I wake up my phone by pressing power button, I have 50/50 chance of it finding the WiFi network. Sometimes it connects and sometimes it just keeps searching and searching, while it stays on the cellular network.
    The way to get it to work is to simply turn WiFi off and back on, and it instantly connects to the WiFi network.
    This happens in multiple WiFi networks, like at home, at work and my inlaws. This used to work flawlessly with Gingerbread 2.3.6 I had prior to upgrade.

    I saw comments on different forum for international SGII phone with couple of different WiFi issues. Anybody here experiences the same issue?

    p.s. Problem solved, scroll down to my last post.
    07-10-2012 08:11 AM
  2. bellington74's Avatar
    The stock ICS update added a new AT&T bloatware app called AT&T wi-fi. Disable or delete it and see if this fixes your wi-fi issue. I had the same problem after updating and removing that fixed it for me.

    Sent from my SAMSUNG-SGH-I777 using Android Central Forums
    maxud likes this.
    07-10-2012 09:47 AM
  3. maxud's Avatar
    Thanks for your tip!
    I removed the application called AT&T smart Wi-Fi.
    I have also disabled Wi-Fi options related to AT&T Wi-Fi spots.

    Did anybody else notice that AT&T misspelled "Notify option"
    it says "Noitfy". Thanks AT&T, it was worth the wait, NOT.

    Anyway, hope this fixes my issue, I will report back in a few days.
    07-10-2012 02:51 PM
  4. maxud's Avatar
    quick update, seems like it fails to connect less than before, but still happens.
    Any other ideas?
    07-12-2012 08:37 AM
  5. bellington74's Avatar
    Well, some people are seeing issues being corrected by doing a factory reset, but as I stated in a different post seen HERE, there is a known and very sever bug that can cause a hard brick when doing this. I know because I hit it. That being said, my replacement phone I got this morning does not seem to have the connection issues I saw on my previous one, and I again took off the AT&T wi-fi app. Driving in it picked up several open hot spots, and so far here at work I have not seen the connection issues when waking up the phone.

    Personally I think the update was borked, and caused more issues than it fixed. If you DO go the route of a factory reset, make sure you have either Samsung or AT&T on the phone with you, and THEY make the recommendation to do it. That way if it does brick, it's because THEY told you to do it and they should do a replacement as they did for me, provided you are still under warranty.

    If I happen across any other helpful tips, aside from "root and flash customer ROM" I will pass it along.
    07-12-2012 09:07 AM
  6. rich.x87's Avatar
    quick update, seems like it fails to connect less than before, but still happens.
    Any other ideas?
    Have you considered rooting?

    Sent from my ASUS Transformer Pad TF300T using Android Central Forums
    07-12-2012 11:23 PM
  7. maxud's Avatar
    I appreciate your suggestion. At this point in time I was just wondering if my phone is unique with this problem, or it is a widespread issue with At&t ICS 4.0.3
    07-13-2012 08:32 AM
  8. maxud's Avatar
    Well, I finally figured out how to solve this problem. In Wi-Fi configuration under advanced options, there is a setting for "Keep Wi-Fi on during sleep". There was a bug in Gingerbread that leaving wi-fi on would drain the battery like crazy, so suggestion was to turn wi-fi OFF during sleep.
    In ICS there are 3 options Always/plugged in/Never.
    When I had Never option selected, I had problems reconnecting to Wi-Fi, not always, just sometimes. I changed it to Always and have not had this issue since!!!
    Thanks to everyone for suggestions
    09-19-2012 03:35 PM
  9. fldude99's Avatar
    Yes that would solve that issue. However, if I find that keeping wifi always is a batter drainer
    09-23-2012 06:34 AM
  10. aabnyy's Avatar
    Hi i also have the same problem, but i can't get your instruction.. Where can i find the AT&T smart wifi? I don't know that, i already upgraded my Samsung S2. Please help, i can't access my Wifi herein my house, i hope you can help. Thank you.
    02-03-2013 05:02 AM