any way to stop chrome?

Dooki

Well-known member
Mar 28, 2013
1,015
3
38
Visit site
I don't use chrome browser, Samsung browser is better for me. The problem being is that chrome is forced to be used. If I try to open an Amazon link from say, the Android Central app, I get a blank open with page. If I enable chrome it gives me the option to open on chrome, which then opens the Amazon app. Another issue is that on a website like the verge comments don't show on Samsung browser but they do with chrome.
Another weird thing is Samsung pay will not verify Visa checkout without chrome. Says chrome is required.
There picture attached is what happens when I try to open an amazing link with chrome disabled.
Any ideas on how to disable chrome without it interfering?
 

Attachments

  • 17972.jpg
    17972.jpg
    12 KB · Views: 50

pool_shark

Well-known member
Aug 21, 2010
1,779
75
0
Visit site
I don't think that's a chrome problem.
I've had this same Amazon link issue.

If I open a link from email that isn't Amazon it opens the Samsung browser and it will eventually open the Amazon link as well.
 

chanchan05

Q&A Team
Nov 22, 2014
8,519
0
0
Visit site
Are you using a theme? I know themes sometimes wreck havoc like that (white on white text) if they haven't been updated properly.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,472
4,606
113
Visit site
After disabling Chrome, make sure Android System Webview is enabled. In Nougat and above, Chrome provides the Android System Webview function, so the actual Android System Webview app is disabled by default. Go to Settings>Apps, tap Menu>Show System, select Android System Webview, then Enable.
 

Mooncatt

Ambassador
Feb 23, 2011
10,738
292
83
Visit site
After disabling Chrome, make sure Android System Webview is enabled. In Nougat and above, Chrome provides the Android System Webview function, so the actual Android System Webview app is disabled by default. Go to Settings>Apps, tap Menu>Show System, select Android System Webview, then Enable.
It should also be noted that both can't be enabled at the same time. You must disable Chrome first. Once System Webview is enabled, you should make sure it's updated in the Play store. If you ever enable Chrome again, it will automatically disable the stand alone System Webview app.
 

Dooki

Well-known member
Mar 28, 2013
1,015
3
38
Visit site
disable chrome, enables web view, enable chrome, disables web view,

doesn't give me an option to manually toggle.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,472
4,606
113
Visit site
In that case, it would be important to make sure Android System Webview is up to date, as mentioned by Mooncatt. If it's disabled, it's the factory installed version, not the most up-to-date one.
 

Trending Posts

Forum statistics

Threads
942,812
Messages
6,915,976
Members
3,158,666
Latest member
Mahendra K