Anybody else having the LTE data drop problem with Rogers on M9 (like Sprint users in the States)?


New member
Jan 31, 2016
Visit site
Hi folks,
I bought my M9 in May, I kind of noticed that it dropped data at that time, but it didn't seem to be that bad. After the 5.1 update in August, it was awful. I called tech support, refreshed my network settings, and replaced the SIM. Nothing worked. Found the workaround by disabling LTE and that kept things stable until the Marshmallow update. Problem is it still happens. For those that aren't familiar here is what happens:
Phone works , then every 11 minutes or so, data drops completely. It cycles from LTE to 3G to edge to nothing. Then a couple of minutes later, incomes back. Often during g this time, I can't send or receive texts, and I suspect that calls may be affected.
Apparently a lot of phones had this issue with 5.1 and had updates to fix it. I hoped that Marshmallow would fix it, but it didn't. I also did a factory reset after the update. many people said it was a radio software issue and those that rooted, used a kicker version and things worked. I'm still under warranty, so I don't want to root. In the US, Sprint users gave had the exact same issues with Spark, their high speed LTE. Many users have reported the exact same issue as I am experiencing. Some users indicate that disabling band 41 significantly improved things. Here in Canada, I assume that is LTE Maxx. I called Rogers about it and they say it's my phone. They did suggest deleting one of my 2 apns LTE.tethering, but I am unable to delete them despite unlocking my phone. Anybody else having this issue with Rogers? Anything work?