Browser redirects itself back to home page

BerryBlack96

Active member
Apr 26, 2012
36
0
0
Visit site
My browser switches back to the homepage almost every time I switch applications unless I switch back right away.
I thought it was a setting within the browser but cannot find anything. I even set the browser back to the original defaults. I also thought it could be a setting in battery Dr saver. But still nothing. is this normal? Any suggestions?
 
Last edited:

J HighNote

Well-known member
Feb 24, 2012
598
15
0
Visit site
I can't offer any help but I have an issue multi tasking with a variety of programs but only sporadically. Sometimes I can bounce between three different programs and never lose my place with none of them having to reopen. Then other times, no matter how I think I'm doing the exact same thing as before, everything seems to reset and need to reload and documents need to open again, etc. While I know this doesn't help you, maybe it points to something other than a browser issue. Up until I saw your message, I figured it was me and I must be doing something different when it doesn't work. I sometimes swipe and get the history instead of a tap to go back, etc. So it wouldn't surprise me if it was my ineptness that causes the issue. I usually use a long hold on the home button to get the most recent programs and USUALLY the programs stay open. Not sure what I occasionally do different. Please post if you figure out a solution, maybe it'll be something that helps me as well.
 

DAS

Well-known member
Feb 9, 2011
1,130
63
0
Visit site
@ The Green Man: Are you using the stock browser? I use Dolphin HD and I can't seem to duplicate your experience.

When I leave the browser and go to a different app, or multiple different apps, and come back to the browser via the multitask method of long pressing the home button it takes me back to the page in the browser I was viewing.

If I understand your problem correctly you're saying that when you did this the browser goes back to the homepage instead?

Please identify which browser you're using.

Galaxy Note! Phone. Tablet. Planner. Notepad. eReader. The only device I need!
 

dakid2k6

Well-known member
Apr 27, 2012
285
4
0
Visit site
it happens to me using stock browser and opera mini. Das thats correct i believe he is saying the same thing as you said.
 

PaulF

Well-known member
Apr 21, 2011
137
18
0
Visit site
I have used caches on other systems so I'm guessing when the browser browser exits it is swapped to the cache and the oldest data in the cache is thrown away if need be. Eventually the browser data will be the oldest, if not accessed, and get tossed. You could try increasing the cache size to see if it gets better. Search for LRU.

Sent from my SAMSUNG-SGH-I717 using Android Central Forums
 

BerryBlack96

Active member
Apr 26, 2012
36
0
0
Visit site
I was using the stock browser. Downloaded opera and now it keeps what I was viewing up but loads the google homepage on a new tab but doesnt do it when I switch between apps. So now it only happens now when I hit the browser button on go launcher. Could it possibly be a setting in go launcher? When I hit the browser button it opens the stock browser then redirects me to opera.

Edit: I have moved the opera app in place of the browser icon. Hopefully this will prevent it from redirecting and bringing up the up extra pages every time.
 
Last edited:

BerryBlack96

Active member
Apr 26, 2012
36
0
0
Visit site
My last reply also leads to my next question. Which browser is everyone using? I like opera better than the stock browser. I am just curious to hear what else is out there and what your experiences have been with other browsers
 

dakid2k6

Well-known member
Apr 27, 2012
285
4
0
Visit site
i use the stock as well as opera. The issue happens on go launcher. But also on holo launcher. I have erased go launcher and just use holo and it does the issue still.
 

Troupe

New member
Dec 31, 2012
1
0
0
Visit site
My browser switches back to the homepage almost every time I switch applications unless I switch back right away.
I thought it was a setting within the browser but cannot find anything. I even set the browser back to the original defaults. I also thought it could be a setting in battery Dr saver. But still nothing. Is this normal? Any suggestions?

I'm not sure if this is your issue, but I developed the same problem on my S3. Go to Settings> System> Developer Options> Apps. Make sure you have not ticked the first box under the Apps Heading that reads, "Do not keep activities. Destroy every activity as soon as the user leaves it". I ticked this box the other day, thinking that closing all activities would save RAM. In doing so, I developed the same problem you're having with your stock browser. After looking around in settings, I realized my mistake. Hope this helps!
 

kurosenpai

Well-known member
May 22, 2012
111
2
0
Visit site
I don't have any problem of that kind but theres this bug when i opened multiple tabs. If i switch apps and get back to the browser all of the web that i have opened would refresh itself. Not really that annoying.

Sent from my GT-N7000 using Tapatalk 2