Choose input method, driving me nuts!

jimhuntphoto

Well-known member
Aug 2, 2013
59
0
0
Visit site
I keep getting this in my notifications menu. I use Swiftkey but this message keeps popping up every day and sometimes multiple times a day. Anyone know how to get it to stop notifying me? Thanks.
 

Javier P

Ambassador
Feb 21, 2014
19,480
4
0
Visit site
I'm not sure if I understand your problem. When you use different keyboards every time you open a text window an icon will appear in the notification bar. That's normal, and expanding it you can change the input method if you want to.

In the settings - language & input you select your default keyboard and that one will be the one that opens when you want to text.

Do you have something different of this?
 
Last edited:

BrainSmashR

Banned
May 4, 2014
132
0
0
Visit site
The only solution I found was to uninstall Swiftkey.
That's a big giant elephant sized bug that needs addressing if it's "normal" behavior as Javier suggested. I mean what's the point of having a default keyboard if I'm asked to choose every single time?!?!?!
 

Javier P

Ambassador
Feb 21, 2014
19,480
4
0
Visit site
The only solution I found was to uninstall Swiftkey.
That's a big giant elephant sized bug that needs addressing if it's "normal" behavior as Javier suggested. I mean what's the point of having a default keyboard if I'm asked to choose every single time?!?!?!

The normal behaviour I said It's the keyboard icon showing in the notification bar, not a menu to choose the input method. As I said, the menu appears only if you scroll down the bar and click on the notification.

And my question was if something different was happening to him.

The OP was talking about a notification, not a pop up.
 

iGalione

Well-known member
Feb 22, 2011
224
1
0
Visit site
unfortunately this is something that was added with the implementation of ICS on android, and it is always there... any input method you have that you are using, it will stay in the notification bar, if and only if a text entry or keyboard is displayed, other than that, it should go away and rid itself until needed again.

PS. I could be wrong on the ICS assumption, but if it wasn't that it was Jellybean, but it is definitely a 4.0 thing
 

raf66

Well-known member
Jul 16, 2010
189
0
0
Visit site
Yeah I get the same thing even though SwiftKey is set as the default input method. What's weird is that even when I uncheck the other keyboards and mark SwiftKey as the default, the next time I go to type something and the keyboard notification pops up, when I go back into Settings/Keyboard, the keyboards I've previously unchecked are now checked. Strange.
 

brentj

Well-known member
Oct 9, 2012
304
0
16
Visit site
It's giving you the option to easily switch keyboards/inputs while you have a keyboard open. When you get done typing and sending your text, email, or whatever, it goes away. Nothing to freak out about!
 

raf66

Well-known member
Jul 16, 2010
189
0
0
Visit site
No freaking out on my end. Just seems odd that when I choose a keyboard as my default, I don't need a reminder to set my keyboard again whenever I use the keyboard-- that I've already chosen. Just seems to be a waste of resources. First world problem, for sure.

I'm enjoying my phone, and frankly if this is my only complaint I would guess that I'm doing ok.
 

akutch34

Trusted Member
May 26, 2011
415
0
0
Visit site
I was pretty irritated with it, too. I've always used Swiftkey... tried out some other keyboards (Swype, Google, Minuum) in hopes that it was only a Swiftkey problem, but the notification still persists... I've just learned to deal with it.
 

jdfry15

Trusted Member
Feb 2, 2011
642
0
0
Visit site
I've got the same issue on my note 4. I believe I've had it on all my recent phones. G3, note 3. I've always used SwiftKey. Annoying, just learned to deal with it I guess.

Posted via the Android Central App
 

Tkbredx

Well-known member
Apr 8, 2012
2,101
58
0
Visit site
Every keyboard does this... No? Either way. I've eliminated it with root. And I really don't feel like undoing it to test this theory so someone try it and let me know how it goes...

When the switch keyboard notification is in the notification drawer. Hold down on it. Click app info (what app is it?). Uncheck the show notifications box. Depending on the app it may hide other notifications. And depending on the app it may not even let you uncheck the box. I can't remember though.
 

jwlehman1

Well-known member
Sep 16, 2012
46
0
0
Visit site
It is irritating... I love the keyboard, but there's no reason for the notification to pop in every time. Users should at least be able to disable it

Posted with my Note 3 via Android Central App
 

Javier P

Ambassador
Feb 21, 2014
19,480
4
0
Visit site
Every keyboard does this... No? Either way. I've eliminated it with root. And I really don't feel like undoing it to test this theory so someone try it and let me know how it goes...

When the switch keyboard notification is in the notification drawer. Hold down on it. Click app info (what app is it?). Uncheck the show notifications box. Depending on the app it may hide other notifications. And depending on the app it may not even let you uncheck the box. I can't remember though.

The origin of that notification it's not an app but Android System. So nothing to uncheck there. Good thought though.

I don't really understand this thread.

If someone has a POPUP every time he opens a keyboard, there's something wrong. Maybe there's some settings in his phone to open a popup when a notification arrives. Or something missing in the input settings. Or something else, because that's not normal.

When you open a keyboard an ICON will appears in the status bar. Just that! and I can't understand how this can be annoying.
 

Trending Posts

Forum statistics

Threads
944,481
Messages
6,922,949
Members
3,159,575
Latest member
100RNR