Exchanging Z1s: intermittent problem with screen registering long press

smurfercom

Well-known member
Jan 25, 2014
63
0
0
Visit site
I've had my phone for a month or so and never ran into that issue, I've dropped it submerged it under water and everything works as it should.
 

mookster

Well-known member
Dec 22, 2010
76
3
0
Visit site
Just curious........

I was reading the Sony manual I downloaded and it mentions a phone reset button that is located under the SIM cover / flap. Have you tried pressing that button? It is not a factory reset, it is designed to reset the phone in case it freezes / crashes.....not suppose to wipe your data.

Sorry for your frustrating experience. I've had my Z1s for close to a month now and not experienced this. I wonder if you have a misbehaving app?

What does the button look like? I had my original phone freeze and it would not reset with the power button. Tmo replaced it but I'm fairly certain a reset button woulda fixed the problem.... Btw, I did see a red button under my Sim flap...

Sent from my C6916 using Tapatalk
 

mookster

Well-known member
Dec 22, 2010
76
3
0
Visit site
OK, good to know. Thanks for sharing, invaluable tip that I wish I knew a coupla weeks ago...

Sent from my C6916 using Tapatalk
 

smurfercom

Well-known member
Jan 25, 2014
63
0
0
Visit site
Yea when I got sick a while back I dl'd the manual and did some hands on training with my new phone. When I read about the reset button I thought why doesn't every phone with embedded battery's have this feature pretty smart sony!

Untitled.jpg