Facebook: Network Error, No Internet Connection

Tigger76

Well-known member
Mar 13, 2011
53
1
0
Visit site
In the last 36 hours I've had an issue with Facebook giving me network errors. It's only happening on my Nexus 10 (my phone running ICS works fine). When I get the error I can check other network connected apps and they work fine. To get Facebook working again I have to close it out, swipe it out of the task list, and restart it. I've tried logging out and back in, clearing all data, and even re-installing, but the problem keeps coming right back.

Is anyone else having this issue and/or does anyone know what I have to do to fix it?
 

sumyunguy

Well-known member
Jun 22, 2010
59
1
0
Visit site
I have had the same issue with my wife's Nexus 7. The first moment we updated the app it gave us a data connection problem. All other apps work fine on the wifi. Just not Facebook for Android. Just keep getting "Network Error"

Here is a Screenshot.
Screenshot_2012-12-15-15-15-05.png
 

a70coupe

New member
Dec 16, 2012
1
0
0
Visit site
I too am having the same "Network Error" with my wife's Nexus7 since the Facebook update. I have rebooted the device, cleared the cache and have also un/installed the app. All other apps on the device are working properly.
 

Tigger76

Well-known member
Mar 13, 2011
53
1
0
Visit site
I'm using version 2.0. I have tried clearing cache, but the problem came back after logging in again. I tried clearing all data but had the same results. I also tried removing the app completely and re-installing from scratch. Still, I end up getting these bogus network errors (it also doesn't matter how close or far away I am from my wifi router, or which wifi router I'm connected to).

This is a Nex 10, 16 gig and I've applied all updates that are available (currently on Android 4.2.1, Kernel 3.4.5-g4e6298b). I found where to submit a bug report to facebook and am doing so. If I here anything back, I'll post it here.
 
Last edited:

Evilnut

Well-known member
Oct 9, 2012
738
0
0
Visit site
I don't use Facebook that much. I just log in about once per week to view pics my daughter posts of my grandkids. Then I log back out. I updated the FB app on my N10 & my Droid4. Last night I logged in from my N10 to see the Santa pic she posted. I had no issues with connectivity. I just logged in from my D4, no issues either. Tried logging in again from my N10, still no issues.

Being a grangpa at only 48 years old to a 2 year old girl & 8 month old twin girls is an amazing thing. I highly recommend it!
 

Devlyn16

Well-known member
Nov 11, 2010
985
1
0
Visit site
I'm using version 2.0. I have tried clearing cache, but the problem came back after logging in again. I tried clearing all data but had the same results. I also tried removing the app completely and re-installing from scratch. Still, I end up getting these bogus network errors (it also doesn't matter how close or far away I am from my wifi router, or which wifi router I'm connected to).

Are you able to log in using the Tablet's Browser at www.facebook.com?
 

Tigger76

Well-known member
Mar 13, 2011
53
1
0
Visit site
Are you able to log in using the Tablet's Browser at www.facebook.com?

I can log in via browser and the browser connection stays up, but I continue to get the network error using the native app. In fact, that's what I've been using since I can't do much with the app before I start getting errors.

I have yet to hear anything back from facebook after posting the bug report to them.
 

mkhall

Well-known member
May 3, 2011
168
2
0
Visit site
I have had the same issue since upgrading the app. There aren't any problems with dropped signals via other apps, just Facebook. It's weird.

Forgot to mention that I'm on an N7, so it's likely a general app problem.
 

D Mac

Well-known member
Dec 8, 2012
55
0
0
Visit site
Yep me too same issue. It's definitely not a Nexus 10 issue or even a Android 4.2.1 issue because I get the same thing on both my tablets running 4.2.1 and my phone running 4.0.4.
 

Devlyn16

Well-known member
Nov 11, 2010
985
1
0
Visit site
Hmmm is your news feed in the app set to top stories or most recent? Mine is set to most recent and I've not experianced this problem.
 

Tigger76

Well-known member
Mar 13, 2011
53
1
0
Visit site
Hmmm is your news feed in the app set to top stories or most recent? Mine is set to most recent and I've not experianced this problem.

I've tried it using both news feed options and it fails with both. I do prefer the most recent setting and use it most often.

I do have to say that for some reason the app has been working fine this evening/night/morning. I haven't done anything different than previous days, but the app hasn't taken the error in over several hours now. I hate intermittent problems, but I'm glad the app is working for now.
 

royal hussar

Well-known member
Nov 20, 2012
52
0
0
Visit site
Started getting the same problems last evening and again this morning. Have not yet tried accessing through the web browser yet but guess its an option. I use facebook a lot and this situation is a real pain. I am also using a Nexus 7 so its seems to be a general problem not just for the N 10
 

darkborne

Member
Jun 25, 2010
20
0
0
Visit site
It's got to be a software issue. I'm getting the same thing on my N10 and Optimus G since updating. Facebook works fine from the browser on both devices.
 

Tigger76

Well-known member
Mar 13, 2011
53
1
0
Visit site
I still haven't heard anything back from my bug report, but I did see that there's an update for the facebook app, so maybe that will fix the issue.
 

Forum statistics

Threads
943,737
Messages
6,919,846
Members
3,159,197
Latest member
ILTAFGICHKI